Support ODROID-XU(+E)

This forum is for supported devices using an ARMv7 Samsung SoC.

Re: Support ODROID-XU(+E)

Postby hkU2 » Sun Oct 13, 2013 8:46 pm

ack, thanks!
hkU2
 
Posts: 7
Joined: Sun Oct 13, 2013 7:03 am

Re: Support ODROID-XU(+E)

Postby WarheadsSE » Mon Oct 14, 2013 3:00 am

Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6807
Joined: Mon Oct 18, 2010 2:12 pm

Re: Support ODROID-XU(+E)

Postby hkU2 » Mon Oct 14, 2013 7:26 pm

you people rawk!
testing,
hkU2
 
Posts: 7
Joined: Sun Oct 13, 2013 7:03 am

Re: Support ODROID-XU(+E)

Postby hkU2 » Wed Oct 23, 2013 12:29 pm

Everything working great on Arch, apart from 2 things:

1) For some reason, the smsc95xx module gets loaded before fs, so it fails when trying to write the eth0 MAC to the fs.
As a result, I get a different MAC address at each boot, which confuses my router/DHCP.
I tried to rmmod smsc95xx, but it appears to be built-in to the kernel? Anyway to change this?
Temporary router-friendly workaround is to boot the board, then plug in the ethernet cable.

2) I can't flash Arch to my eMMC. The procedure in the wiki works fine for the uSD install, but if I attempt the same steps on the eMMC (either from within the XU running on uSD, or by hooking up the eMMC to a uSD converter and on to my Mac), it fails to boot.
I was wondering whether there is something inside xuboot.img that doesn't work with eMMCs.
Unfortunately I do not currently have a UART, so I can't be more useful, i.e. console output, so just checking whether this is a known issue with the team here.
hkU2
 
Posts: 7
Joined: Sun Oct 13, 2013 7:03 am

Re: Support ODROID-XU(+E)

Postby hkU2 » Fri Oct 25, 2013 8:05 pm

1) pacman -Syyu to update the kernel, smsc95xx is not builtin anymore. Thanks folks!
2) still no luck with booting Arch from the eMMC. Any ideas anyone, until my UART arrives?
hkU2
 
Posts: 7
Joined: Sun Oct 13, 2013 7:03 am

Re: Support ODROID-XU(+E)

Postby WarheadsSE » Fri Oct 25, 2013 8:17 pm

Are you supposed to put the uboot onto the eMMC?
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6807
Joined: Mon Oct 18, 2010 2:12 pm

Re: Support ODROID-XU(+E)

Postby hkU2 » Fri Oct 25, 2013 8:39 pm

Are you suggesting keeping u-boot on the uSD card, and modifying it to boot off the eMMC block device instead?
I was looking for a way to fully boot off the eMMC, but that's a good idea to test and see if it works.
hkU2
 
Posts: 7
Joined: Sun Oct 13, 2013 7:03 am

Re: Support ODROID-XU(+E)

Postby hkU2 » Sat Oct 26, 2013 6:18 pm

So modifying boot.ini on the uSD has allowed me to mount the rootfs from the eMMC, which is great until I get my UART and be able to troubleshoot eMMC booting properly.

Next stop: X11
Has anyone set it up successfully yet?
My TV screen remains blank (works fine at 1080p with Android/other Linux distros):

Code: Select all
[root@alarm log]# pacman -Qs xorg
local/xf86-input-evdev 2.8.2-1 (xorg-drivers xorg)
    X.org evdev input driver
local/xf86-video-fbdev 0.4.4-1 (xorg-drivers xorg)
    X.org framebuffer video driver
local/xf86-video-vesa 2.3.2-3 (xorg-drivers xorg)
    X.org vesa video driver
local/xorg-apps 7.6-1
    Transition package depending on various X.Org applications
local/xorg-bdftopcf 1.0.4-1 (xorg xorg-apps)
    Convert X font from Bitmap Distribution Format to Portable Compiled Format
local/xorg-font-util 1.3.0-1 (xorg-fonts xorg)
    X.Org font utilities
local/xorg-font-utils 7.6-3
    Transitional package depending on xorg font utilities
local/xorg-fonts-alias 1.0.3-1
    X.org font alias files
local/xorg-fonts-encodings 1.0.4-3 (xorg-fonts xorg)
    X.org font encoding files
local/xorg-fonts-misc 1.0.1-2
    X.org misc fonts
local/xorg-iceauth 1.0.6-1 (xorg-apps xorg)
    ICE authority file utility
local/xorg-luit 1.1.1-2 (xorg xorg-apps)
    Filter that can be run between an arbitrary application and a UTF-8 terminal emulator
local/xorg-mkfontdir 1.0.7-1 (xorg xorg-apps)
    Create an index of X font files in a directory
local/xorg-mkfontscale 1.1.1-1 (xorg-apps xorg)
    Create an index of scalable font files for X
local/xorg-server 1.14.3-2 (xorg)
    Xorg X server
local/xorg-server-common 1.14.3-2
    Xorg server common files
local/xorg-server-utils 7.6-3
    Transition package depending on xorg server utilities
local/xorg-sessreg 1.0.8-1 (xorg-apps xorg)
    Register X sessions in system utmp/utmpx databases
local/xorg-setxkbmap 1.3.0-1 (xorg-apps xorg)
    Set the keyboard using the X Keyboard Extension
local/xorg-twm 1.0.8-1
    Tab Window Manager for the X Window System
local/xorg-x11perf 1.5.4-1 (xorg-apps xorg)
    Simple X server performance benchmarker
local/xorg-xauth 1.0.8-1 (xorg-apps xorg)
    X.Org authorization settings program
local/xorg-xbacklight 1.2.0-1 (xorg-apps xorg)
    RandR-based backlight control application
local/xorg-xclock 1.0.7-1
    X clock
local/xorg-xcmsdb 1.0.4-1 (xorg-apps xorg)
    Device Color Characterization utility for X Color Management System
local/xorg-xcursorgen 1.0.5-2 (xorg-apps xorg)
    Create an X cursor file from PNG images
local/xorg-xgamma 1.0.5-1 (xorg-apps xorg)
    Alter a monitor's gamma correction
local/xorg-xhost 1.0.6-1 (xorg-apps xorg)
    Server access control program for X
local/xorg-xinit 1.3.3-1
    X.Org initialisation program
local/xorg-xinput 1.6.1-1 (xorg-apps xorg)
    Small commandline tool to configure devices
local/xorg-xkbcomp 1.2.4-1 (xorg-apps xorg)
    X Keyboard description compiler
local/xorg-xkill 1.0.4-1 (xorg-apps xorg)
    Kill a client by its X resource
local/xorg-xmodmap 1.0.8-1 (xorg-apps xorg)
    Utility for modifying keymaps and button mappings
local/xorg-xpr 1.0.4-1 (xorg-apps xorg)
    Print an X window dump from xwd
local/xorg-xrandr 1.4.1-1 (xorg-apps xorg)
    Primitive command line interface to RandR extension
local/xorg-xrdb 1.1.0-1 (xorg-apps xorg)
    X server resource database utility
local/xorg-xrefresh 1.0.5-1 (xorg-apps xorg)
    Refresh all or part of an X screen
local/xorg-xset 1.2.3-1 (xorg-apps xorg)
    User preference utility for X
local/xorg-xsetroot 1.1.1-1 (xorg-apps xorg)
    Classic X utility to set your root window background to a given pattern or color
local/xorg-xwd 1.0.6-1 (xorg-apps xorg)
    X Window System image dumping utility
local/xorg-xwud 1.0.4-1 (xorg-apps xorg)
    X Window System image undumping utility


Code: Select all
[root@alarm log]# dmesg | grep -i hdmi
[    0.000000] Kernel command line: console=ttySAC2,115200n8 vmalloc=512M console=ttySAC2,115200n8 root=/dev/mmcblk1p2 rootwait rw left=56 right=24 upper=3 lower=3 vsync=3 hsync=14 fb_x_res=1920 fb_y_res=1080 vout=hdmi hdmi_phy_res=1080p60hz led_blink=1
[    0.161181] exynos5_odroidxu_display_init : LCD or HDMI or DVI Monitor!
[    0.163279] PowerDomain : pd-hdmi, Device : exynos5-hdmi Registered
[    0.191474] vdd10_hdmi: 1000 mV
[    3.481168] Samsung HDMI output driver, (c) 2010-2011 Samsung Electronics Co., Ltd.
[    3.489083] s5p-hdmi exynos5-hdmi: hdmi ip version = 2
[    3.494186] s5p-hdmi exynos5-hdmi: probe sucessful
[    3.520188] s5p-mixer s5p-mixer: added output 'S5P HDMI connector' from module 's5p-hdmi'
[    4.994462] s5p-hdmi exynos5-hdmi: plugged
[    5.849298] HDMI phy power off : 1


Code: Select all
[root@alarm log]# tail Xorg.0.log
[   121.548] (II) XINPUT: Adding extended input device "odroid-keypad" (type: KEYBOARD, id 7)
[   121.548] (**) Option "xkb_rules" "evdev"
[   121.548] (**) Option "xkb_model" "pc104"
[   121.548] (**) Option "xkb_layout" "us"
[   722.438] (EE) FBDEV(0): FBIOBLANK: Device or resource busy
[   751.437] (II) evdev: odroid-keypad: Close
[   751.437] (II) UnloadModule: "evdev"
[   751.437] (II) evdev: odroidxu-ts: Close
[   751.438] (II) UnloadModule: "evdev"
[   751.446] (EE) Server terminated successfully (0). Closing log file.


Code: Select all
[root@alarm log]# fbset -fb /dev/fb*

mode "1920x1080-60"
    # D: 126.598 MHz, H: 65.527 kHz, V: 60.006 Hz
    geometry 1920 1080 1920 1080 32
    timings 7899 4 4 4 4 4 4
    rgba 8/16,8/8,8/0,0/0
endmode


(probably not needed?)
Code: Select all
[root@alarm log]# cat /etc/X11/xorg.conf
Section "Device"
 identifier "FBDEV"
 Driver "fbdev"
 Option "fbdev" "/dev/fb0"
EndSection

Section "Screen"
 identifier "Default Screen"
 Device "FBDEV"
 DefaultDepth 24
EndSection
hkU2
 
Posts: 7
Joined: Sun Oct 13, 2013 7:03 am

Re: Support ODROID-XU(+E)

Postby raduab » Fri Nov 01, 2013 4:59 pm

I succeeded to install the arch linux arm on the emmc without the need of the microsd for loading its rootfs. Many thanks to the archlinuxarm devs who helped me.

These are the steps:

1. Rebuild the emmc with hardkernel's tool (http://dn.odroid.com/ODROID-XU/Recovery_0.4/). This will restore the original uboot in the emmc card, in case something wiped it.

2. Follow the instructions provided for installing on the micro sd card, skipping the point 3. (there's no need to copy the xuboot.img to the emmc card since the emmc has the uboot already in a hidden partition).

3. Modify the "boot.ini" file from the FAT partition and comment out the "run verify" line (this function is checking if the uboot on the emmc is up to date and if not it rewrites it, but this is not working well and renders the card unbootable).

Insert the card into the board and be sure the swithces are on-on before powering it (for booting from emmc).

Enjoy the best linux distribution on your arm board too!
raduab
 
Posts: 2
Joined: Thu Oct 31, 2013 11:51 am

Re: Support ODROID-XU(+E)

Postby HalosGhost » Fri Nov 01, 2013 9:42 pm

raduab,

I just recently got my XU and I have been excitedly waiting for eMMC support to be functional, so I was ecstatic to hear about your success. Unfortunately, I have not been so lucky.

I think my problem may be on your first step. I cannot find reliable instructions for rebuilding the eMMC with the recovery image. Do I just dd the image over, attach the eMMC to the board with the SD adapter and let it boot from the SD for a while? How do I know when the rebuilding is finished?

All the best,

-HG
HalosGhost
 
Posts: 7
Joined: Fri Jun 29, 2012 8:36 pm

PreviousNext

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest