U-Boot not visible on Chromebook install

This forum is for supported devices using an ARMv7 Samsung SoC.

U-Boot not visible on Chromebook install

Postby ncraike » Wed Oct 02, 2013 9:51 am

I'm following the install instructions here for a Samsung Chromebook, using an SD card as my install media for ArchLinux ARM.

Under the "Create a root USB or SD for dual booting" section, I had a bit of trouble at step 16: after rebooting and pressing Ctrl-U, I didn't see any sign of U-Boot running or counting down. Instead, I just got some screen flicker (display mode change?), a black screen for a couple seconds, then the ArchLinux boot started.

This post was originally going to be a query if the instructions were up-to-date, if it was still expected for me to see U-Boot on a Samsung Chromebook, and if I didn't see it, did I still need to worry about steps 16 to 18. However, I've now realised that U-Boot is in fact running, it's just not visible. If I spam key presses after pressing Ctrl-U, I do get the the U-Boot prompt ("SMDK5250 #"). I just don't get any visible sign U-Boot is running unless I do that.

For usability's sake (and to reduce newbie questions), would it be worth updating those instructions to mention that at step 16, you in fact may not see U-Boot start and count down, but you should just press a key repeatedly to get the prompt anyway?
ncraike
 
Posts: 4
Joined: Wed Oct 02, 2013 9:28 am

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest