[FIXED] Odroid-U2 image broken?

This forum is for supported devices using an ARMv7 Samsung SoC.

[FIXED] Odroid-U2 image broken?

Postby renegat » Sat Oct 12, 2013 6:06 pm

Hello there. Since today I am a proud owner of a ODROID-U2 and I'am now trying to install the one and only OS for me: ArchLinux!
As my rasperry pi is to weak to act as desktop alternative I was hoping the odroid-u2 would fit the requirements.

I created SD card exactly as given in the manual using the latest image. (ArchLinuxARM-odroid-u2-latest.img)
Odroid powers up, blue LED is flashing a little and then falls into a unnormal blinking code:
Two fast blinks, pause, two fast blinks, pause.... As chippey5 described it as 'double flash pattern' in this thread.
I STFW but could not find any documentation on blinking codes like as they are often found accordig to a BIOS (which dosen't exist on Odroid, I know).
The LAN LEDs do nothing, the device does not appear in the routers DHCP table so I can't login via SSH.
When using the original Android SD Card, which came along with the device, everything works as expected - but the blinking of the blue LED is constant and much slower.

Edit I: Meanwhile I've tried several different microSD-cards with all the same negative result. No boot, weird blinking blue led.
So I tried do create a card with the original android image from hardkernel to verify I do not make some mistake when writing the image in general.
I 'dd'ed the image to the card put it in my Odroid and voila: It works flawless! But I'am really no android fan!
I don't want to be disrespectful or insult anybody but could it perhaps be that the issue is founded in the ArchLinuxARM-odroid-u2-latest.img itself (released 06-OCT-2013)?

Edit II: Now I've installed successfully an adroid image, a debian-gnome image and an ubuntu image and all work well but the archlinux-arm image which will still not boot up.

Edit III: As given here I placed a bug report in the GitHub issue queue - hope this would not be considered as double posting.
If so, please delete this post.
Last edited by renegat on Fri Oct 18, 2013 1:41 pm, edited 1 time in total.
Odroid U3+ / U3 / U2 / C1+ / XU4
RPi 1B / 1B+ / 2B / 3B / Zero WH
renegat
 
Posts: 21
Joined: Sat Oct 12, 2013 1:56 pm

Odroid-U2 image IS broken! (does boot but no network up)

Postby renegat » Mon Oct 14, 2013 8:50 am

My bug report was shut down with comment:
'We can't debug based on LEDs. Serial output is needed.'
As I do not own the USB-UART Module Kit (I purchased my Odroid second hand) I'am sorry I cannot deliver the needed information to debug.
It is a great pity that there is no working ArchLinux image for ODroid-U2 and I cannot find a download archive to get an older perhaps working image. :(
So I will have to wait until someone delivers the needed information to the devlopers and meanwhile I have to be satisfied with debian :cry: - but at last their images work like promised!

Edit I: Meanwhile I was given a link to an older image (ArchLinuxARM-2013.06-odroid-u2-rootfs.img) which works fine.
After installation the blue alive led was blinking continous in intervalls of ca. 1sec - as expected.
After pacman -Syu update the intervalls changed to the double blinking pattern which I thought would be an indication for an (boot)-error.
But I was wrong: The old but updated image still works and I can ssh in!
So the change in the flashing frequency of the alive led does NOT indicate an error, it is 'normal' - for the newer/updated versions of the image.

EDIT II:
The newest 'latest image' works. Thank you!
Odroid U3+ / U3 / U2 / C1+ / XU4
RPi 1B / 1B+ / 2B / 3B / Zero WH
renegat
 
Posts: 21
Joined: Sat Oct 12, 2013 1:56 pm


Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest