[jetson tk1] backporting ath10k to the L4T 3.10.40 kernel

This forum is for supported devices using an ARMv7 nVidia SoC.

[jetson tk1] backporting ath10k to the L4T 3.10.40 kernel

Postby la7low » Sun Oct 30, 2016 8:03 pm

Hi all,

I have Arch Linux on my Jetson TK1 after I followed the guide: http://elinux.org/Jetson/Porting_Arch but this way the L4T kernel (version: 3.10.40) is kept, while the linux-armv7 package is ignored from being updated (ignorepckg in the pacman.conf). As a sidenote, with the mainline kernel 4.8rcX the minipcie did not work properly/reliably (see https://devtalk.nvidia.com/default/topic/970855/jetson-tk1/boot-up-hangs-at-quot-1-8v_run_vpp_fuse-bringing-0uv-into-1800000-1800000uv-quot-/) and to my knowledge the GPU drivers for the kepler capabalities are also not included in the mainline kernel.
So I am stuck with 3.10.40 kernel but I would like to use a mini pcie wifi card with the Atheros QCA9880 chip and for that I need the ath10k driver. Now, I was able to install the ath10k driver from the 3.19 backport image but in order to use the latest firmware I need the latest ath10k driver as well from kernel release higher than v4.2 (see https://wireless.wiki.kernel.org/en/users/drivers/ath10k/firmware). So I tried to backport the linux driver from a linux-next release but It did not work, I've got this error message:
Code: Select all
[laco@lacopc backports]$ ./gentree.py --copy-list ./copy-list.ath --integrate --clean --gitdebug --git-revision next-20160324 ~/backports_integrate/linux-next-history/ ~/backports_integrate/kernel/
Get original source files from git ...
Applying patches from patches to /home/laco/Desktop/JetsonArch/compile_kernel/backports_integrate/kernel/backports/ ...
Failed to process SmPL patch collateral-evolutions/generic/0001-group-attr/0001-group_attr_class.cocci with 1
Traceback (most recent call last):
  File "./gentree.py", line 1091, in <module>
    ret = _main()
  File "./gentree.py", line 724, in _main
    logwrite=logwrite)
  File "./gentree.py", line 906, in process
    apply_patches(args, "backport", source_dir, 'patches', bpid.target_dir, logwrite)
  File "./gentree.py", line 605, in apply_patches
    raise Exception('SmPL patch failed')
Exception: SmPL patch failed


In ~/backports_integrate/linux-next-history I cloned: git clone git://git.kernel.org/pub/scm/linux/kern ... istory.git and then git reset --hard next-20160324
In ~/backports_integrate/kernel/ I extraxted the 21.5 L4T 3.10.40 kernel sources (downloaded from https://developer.nvidia.com/linux-tegra-r215).
While the copy-list.ath file I took from this source: http://linuxwireless.org/en/users/Drivers/ath10k/backports/

I have no experience in backporting, so the above error message that it failed to apply some patch does not give me a clue on what to do, so I would appreciate some support on how to go about the above procedure. Can you suggest anything? In case this is not the right forum to ask this, could you tell me where I should raise this question?
Do you know how to find the older linux-next releases from 2015? Even the linux-next-history only contains this years' releases only.
Do you know what is this SmPL patch above? Is it needed for the ath10k driver or can I just skip it somehow?

I read about backporting at these sources too:
https://backports.wiki.kernel.org/index.php/Documentation/integration
https://www.spinics.net/lists/backports/msg04039.html
https://wiki.ubuntu.com/Touch/BluetoothEnablement/NewBackportsPatch
If you know any other good resource/guide, please tell me!

Cheers
Lazlo
la7low
 
Posts: 4
Joined: Sun May 22, 2016 3:07 pm

Return to nVidia

Who is online

Users browsing this forum: No registered users and 1 guest