twonky and subsonic

Request a package to be made here. Make sure you have searched before requesting.

twonky and subsonic

Postby LaTristesse » Wed Jul 28, 2010 10:53 am

I"ve searched the forum for a related topic but it seems nobody is interested either in twonky media server nor subsonic. Is there a way to install this media sevrers or are they allready in the repositories?
LaTristesse
 
Posts: 35
Joined: Mon Jul 26, 2010 8:57 pm

Re: twonky and subsonic

Postby crimsonredmk » Wed Jul 28, 2010 2:22 pm

I don't think Twonky will ever make it (until we hear from their developers) since it's x86-only for now. But you can build and install Subsonic with a little bit of time:

Code: Select all
pacman -Sy yaourt
yaourt -S subsonic


You'll be asked if you want to edit the PKGBUILD file. Say yes. Go down to the arch=('i686'...) line and add 'arm' before the closing ) parenthesis. CTRL+X, and Y to save it. It may ask if you want to edit the install file - say no. It may want to build more stuff - just keep changing the PKGBUILD to be 'arm' and don't edit the install files.

And at the end it'll ask whether it should install the package file. Say yes.
Remember, Arch Linux ARM is completely donation-supported, and is totally awesome.
crimsonredmk
Site Admin
 
Posts: 433
Joined: Wed Dec 30, 2009 5:17 pm
Location: #archlinux-arm on irc.freenode.net

Re: twonky and subsonic

Postby LaTristesse » Fri Jul 30, 2010 3:54 am

thanks for answering. I'll get an error while building:

Code: Select all
=> Continue building subsonic ? [Y/n]
==> ----------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for subsonic:
error: 'jre': could not find or read package

==> WARNING: Dependencies have been installed before the failure
==> Restart building subsonic ? [y/N]
==> ---------------------------------
==>
==> WARNING: Following packages have not been installed:
    subsonic


What does it mean?
LaTristesse
 
Posts: 35
Joined: Mon Jul 26, 2010 8:57 pm

Re: twonky and subsonic

Postby kronos » Sat Oct 16, 2010 1:37 pm

I didn't have any problem getting TwonkyMedia to run:

wget http://www.twonkyforum.com/downloads/6. ... 6.0.23.zip

and then follow the instructions here:

http://www.twonkyforum.com/mediawiki/in ... g/GuruPlug
kronos
 
Posts: 14
Joined: Sat Oct 16, 2010 11:44 am

Re: twonky and subsonic

Postby crimsonredmk » Sat Oct 16, 2010 4:19 pm

Nice, now that we have Java 8-)
Remember, Arch Linux ARM is completely donation-supported, and is totally awesome.
crimsonredmk
Site Admin
 
Posts: 433
Joined: Wed Dec 30, 2009 5:17 pm
Location: #archlinux-arm on irc.freenode.net

Re: twonky and subsonic

Postby zachofalltrades » Wed Oct 20, 2010 8:04 am

Admin wrote:Nice, now that we have Java 8-)


and how do we get java? I'm hitting a wall.
----------
ALARM on TonidoPlug : Nginx, NFS, owncloud
ALARM on RaspberryPi : PocketMine-MP
zachofalltrades
 
Posts: 14
Joined: Thu Jul 22, 2010 5:43 am
Location: Wisconsin, USA

Re: twonky and subsonic

Postby crimsonredmk » Fri Oct 22, 2010 3:13 am

pacman -Sy openjdk6-debian
pacman -Ss openjre (I forgot the actual name of the package, oops)
Remember, Arch Linux ARM is completely donation-supported, and is totally awesome.
crimsonredmk
Site Admin
 
Posts: 433
Joined: Wed Dec 30, 2009 5:17 pm
Location: #archlinux-arm on irc.freenode.net

Re: twonky and subsonic

Postby kronos » Fri Oct 22, 2010 11:19 am

Not sure if you are asking how I installed Java but I didn't. Twonky doesn't need Java, or at least the version I am using.
kronos
 
Posts: 14
Joined: Sat Oct 16, 2010 11:44 am

Re: twonky and subsonic

Postby zachofalltrades » Sat Oct 23, 2010 5:31 am

I had initially installed openjre7, but then subsonic listed openjdk6 as a dependency. And then openjdk6 conflicted with openjre7. I used abs, and modified the subsonic package to depend on openjre7 and then it installed fine. It took a few tries to get it to actually run, and I did not keep a good record of the tweaks I made to finally get it going. But if anyone needs help with it, I'll try to point them in the right direction.
----------
ALARM on TonidoPlug : Nginx, NFS, owncloud
ALARM on RaspberryPi : PocketMine-MP
zachofalltrades
 
Posts: 14
Joined: Thu Jul 22, 2010 5:43 am
Location: Wisconsin, USA

Re: twonky and subsonic

Postby ch33ky » Thu Mar 03, 2011 2:50 am

I'm in the same spot that zachofalltrades was. I get the following error:

Code: Select all
==> Building and installing package
==> Install or build missing dependencies for subsonic:
error: 'jre': could not find or read package
==> WARNING: Dependencies have been installed before the failure
==> Restart building subsonic ? [y/N]


And have no clue how to modify the package with ABS to remove the circular dependency - any help would be appreciated.
ch33ky
 
Posts: 2
Joined: Sun Jan 16, 2011 11:02 am

Next

Return to Package Requests

Who is online

Users browsing this forum: No registered users and 2 guests