xf86-video-imxfb-vivante

Request a package to be made here. Make sure you have searched before requesting.

xf86-video-imxfb-vivante

Postby h4nn35 » Tue Mar 10, 2015 11:13 pm

Hello,

is it possible to get the xf86 imx vivante driver into the repos?
http://git.yoctoproject.org/cgit/cgit.c ... fb-vivante

Because if I use the xf86-video-imx, which is in the repos, on my imx6 board I'll get an error that the driver needs a additional library(libgsl-fsl.so.1) to which I found no relation to. So I suspect that the xf86-video-imx driver is for the imx5x SoCs.
Please correct me if I'm wrong.

Thx in advance!
h4nn35
 
Posts: 2
Joined: Tue Mar 10, 2015 7:12 pm

Re: xf86-video-imxfb-vivante

Postby WarheadsSE » Wed Mar 11, 2015 1:30 am

you might be missing the gpu-viv-bin-mx6q-x11
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6804
Joined: Mon Oct 18, 2010 2:12 pm

Re: xf86-video-imxfb-vivante

Postby h4nn35 » Wed Mar 11, 2015 7:16 am

I have installed that too, but I think/tought I need additionally a xf86 driver. I took a look at sources of the xf86-video-imx and found in the imx_driver.c following code:

/* Supported "chipsets" */
static SymTabRec imxChipsets[] = {
{ 0, "i.MX5x Z160" },
{-1, NULL }
};

So at the moment I'm convinced that the xf86-video-imxfb-vivante is necessary. Because if I take a look at the xorg.conf of the yocto project for the imx6
http://git.yoctoproject.org/cgit/cgit.c ... /xorg.conf
they explicitly name the driver
Driver "vivante"

But the whole vivante setup is a little bit confusing for me at the moment, so I still can be on the completely wrong path.

Thx,
h4nn35
h4nn35
 
Posts: 2
Joined: Tue Mar 10, 2015 7:12 pm


Return to Package Requests

Who is online

Users browsing this forum: No registered users and 2 guests

cron