For use with OXNAS 7820 only. ABORTING!!! UNSUPPORTED MODEL

This is for Community Supported ARMv6 devices that can use the ARMv6h repo

For use with OXNAS 7820 only. ABORTING!!! UNSUPPORTED MODEL

Postby mreg » Sun Jul 21, 2013 9:05 pm

Hi, I'm newbie
I got a POGOPLUG P-24 device that was not working at all, blinking LED all the time.
Followed some post like:
viewtopic.php?f=29&t=3560
http://archlinuxarm.org/platforms/armv6 ... asend-life
and managed to boot the device with a usb stick, to get ip address and log in by ssh. But:
I can't install oxnas with script ./oxnas-install.sh

This is what I got:

Using username "root".
root@192.168.0.102's password:
Last login: Sun Jul 21 14:00:35 2013 from 192.168.0.23
[root@alarm ~]# cd /tmp/
[root@alarm tmp]# wget http://archlinuxarm.org/os/oxnas/oxnas-install.sh
--2013-07-21 15:36:31-- http://archlinuxarm.org/os/oxnas/oxnas-install.sh
Resolving archlinuxarm.org (archlinuxarm.org)... 50.116.36.110
Connecting to archlinuxarm.org (archlinuxarm.org)|50.116.36.110|:80... connected .
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://os.archlinuxarm.org/os/oxnas/oxnas-install.sh [following]
--2013-07-21 15:36:37-- http://os.archlinuxarm.org/os/oxnas/oxnas-install.sh
Resolving os.archlinuxarm.org (os.archlinuxarm.org)... 213.202.193.253, 129.241. 205.167, 137.226.34.42, ...
Connecting to os.archlinuxarm.org (os.archlinuxarm.org)|213.202.193.253|:80... c onnected.
HTTP request sent, awaiting response... 200 OK
Length: 6919 (6.8K) [application/x-sh]
Saving to: `oxnas-install.sh'

100%[======================================>] 6,919 --.-K/s in 0.004s

2013-07-21 15:36:37 (1.66 MB/s) - `oxnas-install.sh' saved [6919/6919]

[root@alarm tmp]# chmod 755 oxnas-install.sh
[root@alarm tmp]# ls
oxnas-install.sh
[root@alarm tmp]# ./oxnas-install.sh
#############################
##
## Pogoplug OXNAS based boards
## Arch Linux ARM rootfs Installer
##
#############################
##
## For use with OXNAS 7820 only.
##
#############################
## PREPARATION
# Switching to /tmp...
# Ensuring we're ready to proceed...
hbwd: no process found
umount: /dev/sda1: not mounted
# Preparing our way...
# Getting uboot parameters...
./oxnas-install.sh: line 25: /usr/local/cloudengines/bin/blparam: No such file o r directory
# = MAC :
# = load_nand :
# = bootargs :
# = board :
#
# Checking board revision...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ABORTING!!! UNSUPPORTED MODEL
=================================
See the wiki on models supported
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

some proc command output:

[root@alarm tmp]# lscpu
Architecture: armv6l
Byte Order: Little Endian
CPU(s): 2
On-line CPU(s) list: 0,1
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 2
[root@alarm tmp]#

[root@alarm tmp]# cat /proc/cpuinfo
Processor : ARMv6-compatible processor rev 5 (v6l)
processor : 0
BogoMIPS : 279.34

processor : 1
BogoMIPS : 279.34

Features : swp half thumb fastmult edsp java
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb02
CPU revision : 5

Hardware : Oxsemi NAS
Revision : 0000
Serial : 0000000000000000
[root@alarm tmp]#


Please help, what am I doing wrong?
THX !
mreg
 
Posts: 1
Joined: Sun Jul 21, 2013 5:00 pm

Re: For use with OXNAS 7820 only. ABORTING!!! UNSUPPORTED MO

Postby WarheadsSE » Mon Jul 22, 2013 1:24 am

Code: Select all
uname -a
pacman -Qi binutils
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm


Return to Community Supported

Who is online

Users browsing this forum: No registered users and 2 guests