Pogoplug update fails

This is for Community Supported ARMv6 devices that can use the ARMv6h repo

Pogoplug update fails

Postby hobbit443 » Sat Sep 07, 2013 10:22 am

Hello,

I've got Archlinux successfull running on my Pogoplug. I extracted the tarball http://archlinuxarm.org/os/ArchLinuxARM-oxnas-latest.tar.gz
Everything worked fine, I can ssh into my Device, but the systemupdate fails:
Code: Select all
error: failed to commit transaction (conflicting files)
filesystem: /bin exists in filesystem
filesystem: /sbin exists in filesystem
filesystem: /usr/sbin exists in filesystem
Errors occurred, no packages were upgraded.

I searched for the problem and got this https://www.archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/.
I followed the steps:
Code: Select all
pacman -Qqo /bin /sbin /usr/sbin | pacman -Qm -
error: cannot determine ownership of directory '/bin'
error: cannot determine ownership of directory '/sbin'
error: cannot determine ownership of directory '/usr/sbin'
error: memory exhausted in argument parsing

and
Code: Select all
find /bin /sbin /usr/sbin -exec pacman -Qo -- {} + >/dev/null
error: cannot determine ownership of directory '/bin'
error: cannot determine ownership of directory '/sbin'
error: No package owns /sbin/devmem2
error: No package owns /sbin/proled
error: cannot determine ownership of directory '/usr/sbin'

I removed /sbin/devmem2 and /sbin/proled. I tried to update:
Code: Select all
 pacman -Syu --ignore filesystem,bash

This seemed to work, after update I installed bash:
Code: Select all
pacman -S bash

and
Code: Select all
:: Starting full system upgrade...
:: Replace dbus-core with core/dbus? [Y/n]
:: Replace nss-myhostname with core/systemd? [Y/n]
resolving dependencies...
...
(97/97) checking for file conflicts                [######################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /bin exists in filesystem
filesystem: /sbin exists in filesystem
filesystem: /usr/sbin exists in filesystem
Errors occurred, no packages were upgraded.

I answered the above questions with "y".
I tried to install filesytem like bash but this produces the same error like systemupgrade.

What can I do?
hobbit443
 
Posts: 2
Joined: Sat Sep 07, 2013 9:40 am

Re: Pogoplug update fails

Postby moonman » Sun Sep 08, 2013 1:09 am

Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 2948
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Pogoplug update fails

Postby hobbit443 » Sun Sep 08, 2013 2:34 pm

Thank you sooo much. It works fine again :)

Code: Select all
[root@alarm ~]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 alarm is up to date
 aur is up to date
:: Starting full system upgrade...
 there is nothing to do
hobbit443
 
Posts: 2
Joined: Sat Sep 07, 2013 9:40 am


Return to Community Supported

Who is online

Users browsing this forum: No registered users and 1 guest