New 3.10.19 kernel with rtl8192cu, i2c spi

This forum is for i.MX233 based devices including the OLinuXino

New 3.10.19 kernel with rtl8192cu, i2c spi

Postby igg » Sun Nov 17, 2013 12:16 am

The short of it:
kernel 3.10.19 with I2C, SPI and functioning kernel-based rtl8192cu driver (EdiMax and friends WiFi module, Realtek RTL8188CUS chips). Updated FS as of 2013-11-16:
A full MMC image with updated rootfs
Build components, patches, etc. in parent directory
There is no auto-connect wifi setup there. The manual style worked for me:
Code: Select all
ip link set wlan0 up
iw wlan0 connect 'My Open SSID'
dhcpcd wlan0

The rtlwifi patch applies to any 3.10 kernel for any architecture that uses the rtl8192cu driver (and probably others). I'm sure the kernel people who worked hard on this would appreciate testers.

The long of it:
I could not get EW-7811Un 802.11n Wireless Adapter (Realtek RTL8188CUS) to work well with kernels > 3.7.
The realtek-supplied driver worked OK, but all versions I tested spammed the log with "OnAction_p2p" at >20 lines/s, causing the system to constantly be in a wait state and rendered the console unusable.
I patched this module to shut it up, but it would not compile with newer kernels, such as 3.10 that I wanted for its long-term support.

The 3.10 and later kernels have their own rtl8192cu module in a new rtlwifi directory. Playing with Jann's excellent site let me build a 3.12.rc3 kernel, but the my EdiMax WiFi adapter did not work. The native module recognized the adapter, uploaded the firmware, and I could get it to scan APs using iw wlan0 scan, and connect to an open AP using iw wlan0 connect 'my open AP'. But that's it. No dhcp, no gateway ping with manual IP. Sound familiar?

This is now bug 60713 on, and a few days ago one of the excellent wireless group people posted a patch.

So, I checked out 3.10.19 from, adapted Fadil Berisha's SPI and I2C patches from Jann's site to work on 3.10 (only a couple adjustments), and then applied the rtlwifi patch from This appears to be working, but of course its too early to tell. This is almost certainly not the final patch to resolve this bug (the bug is still open as of 2013-11-16).

I did the usual things to get a kernel image and went ahead and made a full updated mmc rootfs image to test out my new Google Drive account and make it easier for others to test.
N.B.: I do not have any I2C or SPI hardware to test! Anyone who does, please try it out and report success/failure.

I would have posted this on the olinuxino forum, but I still can't get my account confirmed. I'll send a note there too eventually.

Posts: 1
Joined: Sat Nov 16, 2013 11:16 pm

Return to Freescale i.MX233

Who is online

Users browsing this forum: No registered users and 2 guests