upgrade problem / cryptodev

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

Re: upgrade problem / cryptodev

Postby Sergeanter » Mon May 01, 2017 8:48 pm

You can get it here
http://tardis.tiny-vps.com/aarm/packages/o/openssh/openssh-7.4p1-2-arm.pkg.tar.xz

However rolling openssl-cryptodev back to 1.0 (if you need to ) isn't that simple. pacman -U seems to have a problem with this. You would need to extract libssl and libcrypto from the package in cache.
Sergeanter
 
Posts: 72
Joined: Wed Oct 02, 2013 5:14 am

Re: upgrade problem / cryptodev

Postby kriztioan » Mon May 01, 2017 9:07 pm

Great, thanks! Rolling back openssl might not be necessary. Though, I'll hold off on both for now. Since the affected machine is for home use only and behind the router, there is no *real* need for cryptodev; since the hardware supports is, it was just nice to make use it. My (open)VPN is setup at the router, so no need there either.
Thanks again!
kriztioan
 
Posts: 8
Joined: Sat Apr 29, 2017 1:32 am

Re: upgrade problem / cryptodev

Postby wwenigma » Thu May 04, 2017 12:46 am

Great, i use vpn with it so trying to roll back... :/
wwenigma
 
Posts: 2
Joined: Wed Apr 12, 2017 8:40 am

Re: upgrade problem / cryptodev

Postby kriztioan » Thu May 04, 2017 2:09 am

@wwenigma

tl;dr cryptodev should still be working with openVPN...

I am not aware cryptodev is not working with openVPN; cryptodev is working correctly with the latest kernel and openSSL. An update to openSSH forcing the use of the sandbox crippled cryptodev there; the chrooted/sandboxed forked thread wants to open /dev/crypto and openSSH bails out because it is not allowed to in the sandbox.
kriztioan
 
Posts: 8
Joined: Sat Apr 29, 2017 1:32 am

Previous

Return to Marvell Kirkwood

Who is online

Users browsing this forum: No registered users and 4 guests