Uboot Script doesn't execute on PogoPlug

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

Uboot Script doesn't execute on PogoPlug

Postby Taxicletter » Tue Oct 17, 2017 9:03 pm

Hi,
I'm quite new on Linux and certainly on trying to install something with SSH. I do experiment a lot with my Raspberry to learn.

I have a PogoPlug 2G and succesfully installed Arch on it with these tutorials: https://archlinuxarm.org/platforms/armv ... 2-pinkgray and https://jennifermack.net/2015/02/27/arc ... -pogoplug/

I know Arch is on my USB-key, because I see it if I plug it into another computer.

But the PogoPlug doesn't start Arch, because I failed the last step (I guess).
Code: Select all
/tmp # wget http://os.archlinuxarm.org/os/armv5te/boot/pogo_e02/pogo_e02.sh
Connecting to os.archlinuxarm.org (50.116.36.110:80)
Connecting to de4.mirror.archlinuxarm.org (213.202.193.253:80)
/tmp # chmod +x pogo_e02.sh
/tmp # ./pogo_e02.sh
-sh: ./pogo_e02.sh: not found
/tmp # ls
hbplug.log   pogo_e02.sh  resolv.conf  var          xcehbplug
/tmp # pogo_e02.sh 
-sh: pogo_e02.sh: not found


As you can see, the script is downloaded and I see it with "ls", but when I try to "run" it, it isn't found??

I searched the forum and didn't see an answer. If I missed it, please point me in the right direction!
Thanks!
Taxicletter
 
Posts: 2
Joined: Tue Oct 17, 2017 8:41 pm

Re: Uboot Script doesn't execute on PogoPlug

Postby Taxicletter » Tue Oct 17, 2017 9:14 pm

Since the Pogoplug still works, I went to my account to see my files on the USB-stick.
In the tmp-folder, I didn't see the script. I downloaded it and put it there via the website of my pogo-account. Then I tried again, but still it's not seen. I also put it in "boot", because I read somewhere it should be there. But I cannot "cd" into "boot", it seems.

Code: Select all
~ # cd /tmp
/tmp # chmod +x pogo_e02.sh
/tmp # ./pogo_e02.sh
-sh: ./pogo_e02.sh: not found
/tmp # cd ..
/ # cd /boot
-sh: cd: can't cd to /boot
/ #
Taxicletter
 
Posts: 2
Joined: Tue Oct 17, 2017 8:41 pm

Re: Uboot Script doesn't execute on PogoPlug

Postby karog » Tue Oct 17, 2017 10:53 pm

The chmod seems to find it. ls seems to find it. When in /tmp, show the output of both

Code: Select all
ls -l
cat pogo_e02.sh


For cd /boot show output of

Code: Select all
ls -l /
karog
 
Posts: 183
Joined: Thu Jan 05, 2012 7:55 pm


Return to Marvell Kirkwood

Who is online

Users browsing this forum: No registered users and 2 guests