[How-To] install my.pogoplug.com service on any armv5 device

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby hipnado » Wed Apr 03, 2013 6:21 pm

I've installed this service and have been using it but am unable to use the built-in mirror or archive features. Is this normal and if so, is it possible to get those working?
hipnado
 
Posts: 2
Joined: Tue Apr 02, 2013 10:16 pm

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby gookank » Thu Apr 04, 2013 2:08 am

I have also some problems with it. It is very slow. The WAN speed is around 15KB/sec! I do not know why. I am behind firewalls. Do I need to do anything about firewalls?
gookank
 
Posts: 7
Joined: Sun Mar 31, 2013 7:13 am

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby moonman » Thu Apr 04, 2013 8:15 am

Afaik, it cretes a tunnel to the pogoplug service server so you shouldn't need any portforwarding. I'm not sure why you get such a low speed.
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3324
Joined: Sat Jan 15, 2011 3:36 am

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby grayman4hire » Fri Apr 05, 2013 6:10 pm

I wanted to say thank you moonman!

I've picked up half a dozen or so PogoPlugs so far but never tried the original cloud engine software until last night. I was very pleasantly surprised with the features (given all the negative reviews of the product).

My favorite feature is that the iOS PogoPlug app (which just got totally revamped last week), has the ability to automatically sync/backup your iPhone camera roll (photos and video) to your PogoPlug. Music streaming over the internet, the ability to copy a video back to your iPhone camera roll, and the ability to share files on your PogoPlug via email/URL also deserves notable mention.

BTW, supposedly you're also able to get a free 20GB of cloud storage from PogoPlug if you sign up for Adorama VIP (free) - http://www.adorama.com/pages/vip. I say supposedly because I never received the email from PogoPlug with instructions on how to activate the promotion. I went ahead and emailed PogoPlug support today about it so hopefully I'll get it.

Some constructive feedback regarding the instructions. I was a little confused about the svcid and the /etc/pogoplug.conf file (and how it relates to the /usr/local/cloudengines/hbplug.conf file) . I went through the thread and got it working, but I think the original post could be a little bit more clear.

I know the package is generic for any ARM5 device, but maybe the instructions should be more targeted at PogoPlug owners. Instead of have a new svcid generated, the /etc/pogoplug.conf should just tell the user to use the one from the bottom of their pogoplug.

Code: Select all
#example below: vfsdir<number>=<name>,<path>
vfsdir0=plugdata,/media/2TBDrive/Downloads
installdir=/usr/local/cloudengines
#datadir=.
datadir=.
nohotplug=1
#use the ID from the bottom of your PogoPlug (no dashes)
svcid=


Note: my.pogoplug.com was not able to autodetect my pogoplug. I had to enter my ID on the bottom of my pogoplug and match it up with what was entered in /etc/pogoplug.conf. I guess if it was able to autodetect my pogoplug it would have used the auto generated svcid? It looks like content of /etc/pogoplug.conf is copied to /usr/local/cloudengines/hbplug.conf on start up? Is that correct?
grayman4hire
 
Posts: 350
Joined: Sat Sep 29, 2012 12:03 am
Location: SF, CA

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby rino » Sun Apr 07, 2013 6:09 am

Hi moonman,
Thanks for the new package. I installed pogoplug software, and activated my device. It works fine, however, once I reboot my device, pogoplug seems to forget my HDD. Any idea why? I have to re-activate and add my HDD back again.

I tried both ways - using pacman with the new package, also with the old way of manually installing it (yes, I had to rename the file to install as you've changed the extension of the file). Both results are the same.

I have used this method before, and it used to work fine, but today after the re-install this issue occurred.

Any ideas why?

PS: May be it's a bug in 3.3? I have re-installed alARM, and now waiting for any response here ... I may just go back to 3.2.6 ... I have the tar.gz file for it, but when i tried to copy it on my device and tried to untar it, I got an error file is not in correct format. Any ideas about it?

EDIT: I have installed 3.2.6 now, but same thing is happening ... after reboot, pogoplug doesn't recognize my external HDD attached. What am I doing wrong? Is there anything that I am missing in the config file? Help plz!

Regards,
-Riaz
rino
 
Posts: 66
Joined: Mon Jan 07, 2013 3:21 pm

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby rino » Sun Apr 07, 2013 12:28 pm

What are the differences between 3.2.6 and 3.3 anyways? (if there are any)

Also, now that I have 3.2.6 installed, can I just upgrade it to 3.3 using pacman -U or will I have to reinstall alARM, and then do a fresh install of 3.3?
rino
 
Posts: 66
Joined: Mon Jan 07, 2013 3:21 pm

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby grayman4hire » Sun Apr 07, 2013 6:20 pm

Regard rebooting and losing your settings, check that your /etc/pogoplug.conf file is how you want it (correct svcid and name/path).
grayman4hire
 
Posts: 350
Joined: Sat Sep 29, 2012 12:03 am
Location: SF, CA

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby rino » Sun Apr 07, 2013 8:35 pm

Thanks grayman4hire ... I put the svcid in the pogoplug.conf, and it did the trick. I reinstalled alARM, and installed the new pogoplug firmware (3.3.0) + added the svcid. My problem has been solved.

Thanks again :)
rino
 
Posts: 66
Joined: Mon Jan 07, 2013 3:21 pm

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby moonman » Tue Apr 09, 2013 4:33 am

It may not be generating the proper svcid in the package I provided. Currently I don't know of any reliable way to do that. You may need to run hbplug a couple of time before it acquire all the needed certificates and generates the svcid. I would say either copy /usr/local/cloudengines/bin/hbplug.conf to /etc/Arch Linux ARM install.conf and use it as a template after you are certain it has svcid and certificates (e.g. when you run hbplug it says CERT: VALID) or copy the svcid from the bottom of the device as greyman4hire suggested.

Yes. Arch Linux ARM install.conf gets copied to /usr/local/cloudengines/bin/hbplug.conf on startup.
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3324
Joined: Sat Jan 15, 2011 3:36 am

Re: [How-To] install my.pogoplug.com service on any armv5 de

Postby Highvoltag3 » Sat Apr 13, 2013 5:38 am

Everything worked out perfectly for me, except for the Sharing in the WebUI. It shows the Spinner like it is processing the file I want to share and then responds with an error.

No luck on any type of files, anyone else having this issue?
Highvoltag3
 
Posts: 45
Joined: Sat Mar 19, 2011 10:28 am

PreviousNext

Return to Marvell Kirkwood

Who is online

Users browsing this forum: No registered users and 5 guests