xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.0.0-

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.0.0-

Postby jacgl » Sat Apr 18, 2015 7:11 am

Hi,
I am usig Pogoplug4 with 1usb2.0 and 2 Fresco usb3.0 ports.

With fresh install of archlinux on usb stick
#wget http://archlinuxarm.org/os/ArchLinuxARM ... est.tar.gz
#tar -xzvf ArchLinuxARM-kirkwood-latest.tar.gz
all usb port are visible and works properly.

[root@alarm ~]# usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 2
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=03.19
S: Manufacturer=Linux 3.19.3-1-ARCH xhci-hcd
S: Product=xHCI Host Controller
S: SerialNumber=0000:00:01.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=5000 MxCh= 2
D: Ver= 3.00 Cls=09(hub ) Sub=00 Prot=03 MxPS= 9 #Cfgs= 1
P: Vendor=1d6b ProdID=0003 Rev=03.19
S: Manufacturer=Linux 3.19.3-1-ARCH xhci-hcd
S: Product=xHCI Host Controller
S: SerialNumber=0000:00:01.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=03.19
S: Manufacturer=Linux 3.19.3-1-ARCH ehci_hcd
S: Product=EHCI Host Controller
S: SerialNumber=orion-ehci.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=03 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0781 ProdID=5572 Rev=01.27
S: Manufacturer=SanDisk
S: Product=Cruzer Switch
S: SerialNumber=20044321721DA46010DA
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage


After package upgrade usb3.0 ports dissapeard!
[root@alarm ~]# usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=04.00
S: Manufacturer=Linux 4.0.0-1-ARCH ehci_hcd
S: Product=EHCI Host Controller
S: SerialNumber=orion-ehci.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0781 ProdID=5572 Rev=01.27
S: Manufacturer=SanDisk
S: Product=Cruzer Switch
S: SerialNumber=20044321721DA46010DA
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

Seems that linux-kirkwood-4.0-1 is problematic. The change is 3.19.3-1 -> 4.0.0-1.

BTW, the what the upgrade did is:
#pacman -Syu
Packages (10) ca-certificates-20150402-1 ca-certificates-utils-20150402-1 glib2-2.44.0-1 gnutls-3.3.14-2 groff-1.22.3-3
libssh2-1.5.0-1 libtasn1-4.4-1 linux-kirkwood-4.0-1 lz4-128-1 man-pages-3.82-1

Regards,
Jacek
jacgl
 
Posts: 4
Joined: Fri Apr 17, 2015 10:45 pm

Re: xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.

Postby moonman » Sat Apr 18, 2015 8:54 am

You can rollback the kernel http://rollback.archlinuxarm.org/packag ... pkg.tar.xz
Seems like a bug in 4.0.0. Hopefuly 4.0.1 will fix this.
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3302
Joined: Sat Jan 15, 2011 3:36 am

Re: xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.

Postby bodhi » Sun Apr 19, 2015 8:49 pm

@moonman,

It does look like a PCI bug, at least in Kirkwood. It seems like the same problem for the iConnect PCIe wifi card.

-bodhi
bodhi
 
Posts: 224
Joined: Sat Aug 13, 2011 10:06 am

Re: xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.

Postby sakaki » Thu Apr 30, 2015 8:51 am

Hi,

you are correct; there is a confirmed PCI bug in 4.0 affecting Kirkwood; please see my post here.

Best

sakaki
sakaki
 
Posts: 11
Joined: Sat Mar 28, 2015 1:53 pm

Re: xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.

Postby bodhi » Thu Apr 30, 2015 1:34 pm

sakaki wrote:Hi,

you are correct; there is a confirmed PCI bug in 4.0 affecting Kirkwood; please see my post here.

Best

sakaki


Thanks. We can confirm the patch indeed solved the problem for USB 3.0 on Pogo V4 and iConnect PCIe wifi:
http://forum.doozan.com/read.php?2,1209 ... #msg-21560.

And appreciated you did the hard work bisecting :)

-bodhi
bodhi
 
Posts: 224
Joined: Sat Aug 13, 2011 10:06 am

Re: xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.

Postby moonman » Thu Apr 30, 2015 11:36 pm

Kernel 4.0.1 is in repos with this bug fixed (thanks to sakaki).
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3302
Joined: Sat Jan 15, 2011 3:36 am

Re: xHCI timeout after upgrade linux-kirkwood 3.19.3-1 -> 4.

Postby llsth » Fri May 01, 2015 1:07 pm

Kernel 4.0.1 is in repos with this bug fixed (thanks to sakaki).

I just did an upgrade on my Excito B3 to the latest kernel and I can confirm the wireless adapter shipped with B3 now works again.
llsth
 
Posts: 1
Joined: Fri May 01, 2015 1:03 pm


Return to Marvell Kirkwood

Who is online

Users browsing this forum: No registered users and 4 guests