Driver issues on TI Nspire

This forum is for all other ARMv5 devices

Driver issues on TI Nspire

Postby meurer » Fri Jun 03, 2016 5:34 pm

Recently I came across this article regarding how to get Debian for ARM to run on the TI Nspire CX calculator (that has a 150MHz ARMv5 processor). I followed that guide and got it working (I even got OpenBox to run on it) but, since I'm not the biggest fan of Debian, I've been trying to get Arch on it.

I downloaded the ARMv5 Multi-platform release, unpacked the contents on the EXT-4 formatted USB drive and, surprise surprise, it booted! I went on to setting up a correct fstab and other system configs and I successfully managed to get things like VIM and xorg running on it by chrooting onto the drive using qemu-arm-static as I saw here. The problems began once I plugged in my rtl8192cu based USB wi-fi dongle, which supposedly has it's drivers built into the kernel, but wasn't working. I tried to run `depmod -a` and got this on the chroot:

Code: Select all
sh-4.3# depmod -a
depmod: ERROR: could not open directory /lib/modules/4.5.4-1-ARCH: No such file or directory
depmod: FATAL: could not search modules: No such file or directory


And this on the calculator (Note: The hostname is set to nspire):

Code: Select all
[root@nspire ~] depmod -a
depmod: ERROR: could not open directory /lib/modules/4.3.0-rc1-next-20150914-nspire: No such file or directory
depmod: FATAL: could not search modules: No such file or directory


I ran a couple more commands on the chroot to try and find out what was wrong:

Code: Select all
sh-4.3# uname -r
4.5.4-1-ARCH
sh-4.3# ls -la /lib/modules
total 32
drwxr-xr-x  4 root root  4096 May 16 03:38 .
drwxr-xr-x 52 root root 20480 Feb 22 14:47 ..
drwxr-xr-x  3 root root  4096 Jun  1 02:51 4.6.0-1-ARCH
drwxr-xr-x  2 root root  4096 May 16 03:38 extramodules-4.6--armv5


And then on the calculator

Code: Select all
[root@nspire ~] uname -r
4.3.0-rc1-next-20150914-nspire
[root@nspire ~] ls -la /lib/modules
total 32
drwxr-xr-x  4 root root  4096 May 16 03:38 .
drwxr-xr-x 52 root root 20480 Feb 22 14:47 ..
drwxr-xr-x  3 root root  4096 Jun  1 02:51 4.6.0-1-ARCH
drwxr-xr-x  2 root root  4096 May 16 03:38 extramodules-4.6--armv5
[root@nspire ~] lsmod
libkmod: kmod_module_new_from_loaded: could not open /proc/modules: No such file or directory
Error: could not get list of modules: No such file or directory
[root@nspire ~] lsusb | grep 8192
Bus 001 Device 009: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
[root@nspire ~] iw dev
[root@nspire ~] ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: tun10@NONE: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default
   
    link/ipip 0.0.0.0 brd 0.0.0.0
3: sit0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default
    link/sit 0.0.0.0 brd 0.0.0.0


Another issue I've been having is that my Microsoft USB keyboard works just fine, so does an LG one I have, but a Mac USB Aluminium keyboard I have doesn't work at all. I know this is an unusual environment to say the least, but since Debian worked I was hoping I'd be able to set this up as well. Also note that all the terminal output from the calculator has been hand copied, so typos are possible (specially with the tiny font on the LCD). With that said, why are the drivers not loading and depmod not working? How can I solve this?
meurer
 
Posts: 1
Joined: Fri Jun 03, 2016 4:46 pm

Return to Community Supported

Who is online

Users browsing this forum: No registered users and 3 guests