lsusb and ldconfig

This forum is for all other ARMv5 devices

lsusb and ldconfig

Postby franoreilly » Sun May 01, 2011 1:03 pm

Hi,

I have a PogoPlug Pro with Arch Linux ARM installed - which went without a hitch. I've even got my wireless working and hooked up to my WPA2 network - so far, so spiffy.

I'm now trying to get it working as a print server for my USB printer using CUPS so I've installed the CUPS package and hplip using pacman (with sources updated). However, I see the following issues with lsusb and ldconfig:
Code: Select all
[root@Arch Linux ARM install ~]# lsusb
*** glibc detected *** lsusb: free(): invalid pointer: 0xbec4bb6c ***
Aborted

Not sure if lsusb had this issue before the installs.

Code: Select all
[root@Arch Linux ARM install ~]# ldconfig
ldconfig: /usr/lib/libijs-0.35.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libijs.so is not an ELF file - it has the wrong magic bytes at the start.

libijs.so I am assuming is part of the hpijs package which gets installed with hplip. It seems like it's not been compiled properly for this platform?

Any advice? Cheers!
franoreilly
 
Posts: 3
Joined: Sun May 01, 2011 12:21 pm

Return to Community Supported

Who is online

Users browsing this forum: No registered users and 3 guests