[How-To] Enable Wireless

This forum is for all other ARMv5 devices

[How-To] Enable Wireless

Postby WarheadsSE » Fri Dec 09, 2011 8:34 pm

Credit to Scorp / Geoff for collecting all of this:

scorp wrote:
note: i had wifi working with the original pogoplug software first

then installing archlinux arm as descriped.

this worked for me to get wifi again:

Code: Select all
pacman -S wifi-select  #follow instructions after that, this will install iwlist, iwpriv and so on, used by franoreillys script

mkdir /tmp/ce

mount -t ubifs -o ro ubi0:rootfs /tmp/ce

mkdir /etc/Wireless

/bin/cp -rfv /tmp/ce/etc/Wireless/RT2860STA /etc/Wireless

mkdir  /lib/modules/2.6.31.6_SMP_820/kernel/drivers/net/wireless

cp /tmp/ce/lib/modules/2.6.31.6_SMP_820/kernel/drivers/net/wireless/rt3390sta.ko /lib/modules/2.6.31.6_SMP_820/kernel/drivers/net/wireless/rt3390sta.ko

depmod -a



franoreilly wrote:Changed the MODULES line in /etc/rc.conf line to :

Code: Select all
MODULES=(gmac rt3390sta !rt2800pci)



franoreilly's method:
scorp wrote:Now i followed the instructions of franoreilly:
Created a script file /usr/local/bin/setup_wireless containing (assumes a WPA2 TKIP wifi configuration):

Code: Select all
ifconfig ra0 up
iwpriv ra0 set NetworkType=Infra
iwpriv ra0 set AuthMode=WPA2PSK
iwpriv ra0 set EncrypType=TKIP
iwpriv ra0 set SSID="Your wireless access point name"
iwpriv ra0 set WPAPSK=your wireless access point password
#setting up a static ip address
ifconfig ra0 192.168.0.123 netmask 255.255.255.0   #use your own preferred static ip/netmask 
route add default gw 192.168.0.1   #use ip of your router/gateway


Make the script executable (you might also need to consider more restrictive permissions since the script file contains your wifi password):

Code: Select all
chmod +x /usr/local/bin/setup_wireless


Run the script on boot, add the following line to the end of /etc/rc.local:

Code: Select all
/usr/local/bin/setup_wireless


Geoff's method
Geoff wrote:I found an alternative, which I think follows more closely the intent of the rc system. I decided to use a static IP address for eth0 and another static IP address for ra0, so I changed /etc/rc.conf as follows:

Code: Select all
#Static IP example
eth0="eth0 192.168.0.7 netmask 255.255.255.0 broadcast 192.168.0.255"
#eth0="dhcp"
ra0="ra0 192.168.0.207 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(eth0 ra0)

As I am using static IP addresses for eth0 and ra0, I added static default gateways for each of these, giving a higher priority to eth0:

Code: Select all
#gateway="default gw 192.168.0.1"
#ROUTES=(!gateway)
gateway_eth0="default gw 192.168.0.1 metric 0 dev eth0"
gateway_ra0="default gw 192.168.0.1 metric 1 dev ra0"
ROUTES=(gateway_eth0 gateway_ra0)

Finally, I added some lines to the end of /etc/conf.d/wireless to set the wireless password:

Code: Select all
iwpriv ra0 set EncrypType=TKIP
iwpriv ra0 set WPAPSK='Your wireless access point password'
wlan_ra0="ra0 mode managed essid 'Your wireless access point name' auth WPA2"
WLAN_INTERFACES=(ra0)


Finally: reboot the Pogoplug Pro
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: [How-To] Enable Wireless

Postby WarheadsSE » Sat Dec 10, 2011 5:32 am

And here is what I ended up doing:

- Grab Driver
- Edit rc.conf to load the driver (no blacklists at all)
- mkdir /etc/wireless
- nano /etc/wireless/wlan
Code: Select all
ifconfig ra0 up

sleep 1

iwpriv ra0 set WirelessMode=Managed
iwpriv ra0 set AuthMode=WPA2PSK
iwpriv ra0 set EncrypType=TKIP
iwpriv ra0 set SSID=DERP
iwpriv ra0 set WPAPSK=**********
# trust me.
sleep 1

# I like dhcp.
dhcpcd ra0

- chmod +x /etc/wireless/wlan
- edit rc.local & add /etc/wireless/wlan
- reboot.

Everything worked for me.

Best method would be the /etc/network.d/ & NETWORKS in rc.conf.. but I will admit I am unfamiliar with them.

There have been some reports of "not working" if you configure & spin up the wifi with the ethernet still attached, then remove the ethernet. The problem here: gateways. Look up setting the default gateway.

https://wiki.archlinux.org/index.php/Co ... _Addresses
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: [How-To] Enable Wireless

Postby ZzyzxOh » Thu Dec 15, 2011 4:23 am

I took my first shot at Wireless on the PogoPlugPro tonight, about an hour after getting it. I needed time to install Apache, PHP and MySQL, which went pretty well except for the MySQL defaults for buffers allocated. I think it would have been ten minutes total, otherwise.

Wireless seems a lot more complicated, for some reason. I was stepping through the various approaches and did manage to make both the wired and wireless dead, and I thought I'd be splitting the case open on a shiny, new Pro and working with the serial header.

But sometimes the simple way is the best way. As I struggled to remove the side panel without breaking anything, I realized I didn't need to go inside. I simply removed the boot thumb-drive, plugged it into my Linux desktop and edited rc.conf as root. After I commented out the few lines that I added, I put the thumb back into the PPP and it booted up nicely, albeit without WiFi.

I need to do a little more research on this setup, and I like this latest posting with DHCP, which I much prefer to static addresses. But I need that hostname to be the "regular" hostname with WiFi on the end, so I can reach it with a unique name. (i.e. alarm, alarm-wifi) More to do.

I want to add a word of thinks for everyone who posts here, both questions and answers. I find this an excellent resource and I just may end up with "one of each" before too long. (Love the looks of the Series 4, but not the developer price.)

Cheers!
ZzyzxOh
 
Posts: 6
Joined: Thu Dec 15, 2011 4:09 am

Re: [How-To] Enable Wireless

Postby dinjo » Sat Jan 21, 2012 4:43 pm

Can't get wireless working


Code: Select all
  17.780000] eth0: PHY is Realtek RTL8211D, type 0x001cc914
[   17.780000] CoPro offload is active on eth0
[   17.790000] Alloc'ing ARM descs 8192 bytes
[   17.800000] Alloc'ing CoPro parameters 36 bytes
[   17.800000] gmac gmac.0: firmware: requesting gmac_copro_firmware
[   17.830000] CoPro: Programming start address as 0xd000e000
[   17.940000] eth0: Resetting GMAC
[   17.940000] eth0: GMAC reset complete
[   17.950000] eth0: Setting Rx flow control thresholds for LAN port
[   18.500000] eth0: PHY is Realtek RTL8211D, type 0x001cc914
[   19.000000] eth0: link down
[   20.960000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   21.000000] eth0: link up, 100Mbps, full-duplex, using pause, lpa 0x45E1
[   21.000000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   31.360000] eth0: no IPv6 routers present
[   65.120000] RX DESC ffc18000  size = 2048
[   65.120000] <-- RTMPAllocTxRxRingMemory, Status=0
[   65.140000] Key1Str is Invalid key length(0) or Type(0)
[   65.140000] Key2Str is Invalid key length(0) or Type(0)
[   65.150000] Key3Str is Invalid key length(0) or Type(0)
[   65.150000] Key4Str is Invalid key length(0) or Type(0)
[   65.160000] 1. Phy Mode = 9
[   65.160000] 2. Phy Mode = 9
[   65.160000] NVM is Efuse and its size =2d[2d0-2fc]
[   65.170000] 3. Phy Mode = 9
[   65.230000] RTMPSetPhyMode: channel is out of range, use first channel=1
[   65.240000] MCS Set = ff 00 00 00 01
[   65.250000] <==== rt28xx_init, Status=0
[   65.250000] 0x1300 = 00064300
[   65.250000]  AUX_CTRL = 0x                            4c02
[   65.260000]  Read AUX_CTRL = 0x4c02
[   65.260000]  Write AUX_CTRL = 0x5c02
[   65.270000]  OSC_CTRL = 0x3ff11
[   65.270000] ====> rt30xx Read PowerLevelMode =  0x3.
[   65.270000] ====> rt30xx F Write 0x83 Command = 0x3.
[   68.130000] ------------[ cut here ]------------
[   68.130000] WARNING: at kernel/softirq.c:143 local_bh_enable_ip+0x70/0xa0()
[   68.130000] Modules linked in: bootled_module gmac mii rt3390sta
[   68.130000] [<c002e1fc>] (unwind_backtrace+0x0/0xe0) from [<c0048ac4>] (warn_slowpath_common+0x48/0x60)
[   68.130000] [<c0048ac4>] (warn_slowpath_common+0x48/0x60) from [<c004dea0>] (local_bh_enable_ip+0x70/0xa0)
[   68.130000] [<c004dea0>] (local_bh_enable_ip+0x70/0xa0) from [<bf0d0d44>] (RtmpAsicSendCommandToMcu+0x458/0x4a4 [rt3390sta])
[   68.130000] [<bf0d0d44>] (RtmpAsicSendCommandToMcu+0x458/0x4a4 [rt3390sta]) from [<bf060738>] (T.1819+0x2c/0x38 [rt3390sta])
[   68.130000] [<bf060738>] (T.1819+0x2c/0x38 [rt3390sta]) from [<bf06c8b4>] (AsicAdjustTxPower+0x26c/0x2d5c [rt3390sta])
[   68.130000] [<bf06c8b4>] (AsicAdjustTxPower+0x26c/0x2d5c [rt3390sta]) from [<bf02645c>] (STAMlmePeriodicExec+0x254/0xb90 [rt3390sta])
[   68.130000] [<bf02645c>] (STAMlmePeriodicExec+0x254/0xb90 [rt3390sta]) from [<bf02722c>] (MlmePeriodicExec+0x494/0x6ac [rt3390sta])
[   68.130000] [<bf02722c>] (MlmePeriodicExec+0x494/0x6ac [rt3390sta]) from [<bf059854>] (rtmp_timer_MlmePeriodicExec+0x1c/0x38 [rt3390sta])
[   68.130000] [<bf059854>] (rtmp_timer_MlmePeriodicExec+0x1c/0x38 [rt3390sta]) from [<c0052878>] (run_timer_softirq+0x118/0x200)
[   68.130000] [<c0052878>] (run_timer_softirq+0x118/0x200) from [<c004dd40>] (__do_softirq+0xa8/0x140)
[   68.130000] [<c004dd40>] (__do_softirq+0xa8/0x140) from [<c004e198>] (irq_exit+0x84/0xa0)
[   68.130000] [<c004e198>] (irq_exit+0x84/0xa0) from [<c0028290>] (do_local_timer+0x54/0x70)
[   68.130000] [<c0028290>] (do_local_timer+0x54/0x70) from [<c0028af8>] (__irq_svc+0x38/0xc0)
[   68.130000] Exception stack(0xc03cff50 to 0xc03cff98)
[   68.130000] ff40:                                     00000000 00000000 c03cff98 00000000
[   68.130000] ff60: c03ce000 c03f5664 c03d40c4 c03ce000 c0022000 c0023180 c03d3e08 c03f53e0
[   68.130000] ff80: c0526050 c03cff98 c0029a1c c0029a20 60000013 ffffffff
[   68.130000] [<c0028af8>] (__irq_svc+0x38/0xc0) from [<c0029a20>] (default_idle+0x24/0x28)
[   68.130000] [<c0029a20>] (default_idle+0x24/0x28) from [<c0029be8>] (cpu_idle+0x6c/0xa4)
[   68.130000] [<c0029be8>] (cpu_idle+0x6c/0xa4) from [<c0008a10>] (start_kernel+0x31c/0x384)
[   68.130000] [<c0008a10>] (start_kernel+0x31c/0x384) from [<60008084>] (0x60008084)
[   68.130000] ---[ end trace e29fb07260958957 ]---
dinjo
 
Posts: 258
Joined: Mon Nov 28, 2011 5:59 am

Re: [How-To] Enable Wireless

Postby WarheadsSE » Sat Jan 21, 2012 11:28 pm

dinjo, I've see this before.

Try it ;)

That module loves to throw errors.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: [How-To] Enable Wireless

Postby dinjo » Sun Jan 22, 2012 3:07 am

I tried your method too wifi signal is not recognized ? What can i do to investigate further.
dinjo
 
Posts: 258
Joined: Mon Nov 28, 2011 5:59 am

Re: [How-To] Enable Wireless

Postby dinjo » Sun Jan 22, 2012 1:20 pm

Any help here ?
dinjo
 
Posts: 258
Joined: Mon Nov 28, 2011 5:59 am

Re: [How-To] Enable Wireless

Postby Socaltom » Sun Mar 04, 2012 5:25 pm

WarheadsSE wrote:And here is what I ended up doing:

- Grab Driver


Could you expand on this part? I'm getting the following errors when I run your script from the command line
Code: Select all
ra0: ERROR while getting interface flags: No such device
ra0       no private ioctls.

ra0       no private ioctls.

ra0       no private ioctls.

ra0       no private ioctls.

ra0       no private ioctls.

dhcpcd[1178]: version 5.5.4 starting
dhcpcd[1178]: ra0: interface not found or invalid


lsmod gives me this
Code: Select all
Module                  Size  Used by
gmac                   40372  0
mii                     6328  1 gmac


So I don't think I have the module, if I do, its in the wrong place.
Thanks
Tom
Owned by me
Pink Pogo V2, Black Pogo V3, Zyxel NAS 325 v1,
Adminstrator for
Goflex net, Black V3, Black V2
Socaltom
 
Posts: 567
Joined: Thu Apr 07, 2011 2:21 pm
Location: The left side

Re: [How-To] Enable Wireless

Postby WarheadsSE » Sun Mar 04, 2012 6:03 pm

See scorp's instructions to copy it from NAND (e.g. /tmp/ce ~)
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: [How-To] Enable Wireless

Postby Socaltom » Mon Mar 05, 2012 2:09 am

I followed scorps instructions, but the file didn't appear where it should. I eventually found it in the 3.10.1-3-ARCH files I got somewhere. I copied it over and it worked. I used the combination of scorps instructions and Warheads. I also added a couple of items to the rc.conf file.

Code: Select all
ra0="dhcp"
INTERFACES=(eth0 ra0 )


FWIW, I've got wired and wireless working at the same time.
Tom
Owned by me
Pink Pogo V2, Black Pogo V3, Zyxel NAS 325 v1,
Adminstrator for
Goflex net, Black V3, Black V2
Socaltom
 
Posts: 567
Joined: Thu Apr 07, 2011 2:21 pm
Location: The left side

Next

Return to Community Supported

Who is online

Users browsing this forum: No registered users and 2 guests