Can I unbrick it? (B01 won't boot/connect)

This forum is for all other ARMv5 devices

Can I unbrick it? (B01 won't boot/connect)

Postby mrhuge » Fri Jan 25, 2013 1:18 am

I just started playing with my new Pogoplug B01 a few days ago, and I'm a linux newb, so it's easily believable that I just did something stupid at some point...

I installed Arch fine, got samba working nicely with my Windows 7 network, and then started working on rtorrent/rutorrent. I had a lot of trouble figuring out the right steps to take, so it seems likely I went wrong somewhere in here. At some point I tried to reboot and got the dreaded fast-flashing green light, which didn't stop flashing after 15 minutes or so. Powering down and back up produces the same result. With the USB flash drive (& ext HD) removed, it flashes green and then resolves to orange. In all cases my router does not detect a device detected anymore, so of course I can't SSH.

So I thought "OK, I'll just re-install everything" (which didn't seem like a bad idea anyway given how much splashing around I had done trying to get things set up), but then I remembered that initially I had to set up the USB drive *USING* the pogoplug. I don't have any other linux devices, so I downloaded gparted and booted up a (usually)windows box with the Gparted Live CD. I could see the contents of the USB drive, so I tried to do whatever repair I could and tried the pogo again - same result.

So back to reinstall ... I hoped I could just install Arch from Gparted, but I'm not sure that would work, and it doesn't come with wget, so I'm at the end of my rope...

Do I need to create the ArchLinux install disk on the machine on which I will do the install?

Or does it need to be created on Arch? (ie can it be Debian or Ubuntu or whatever - Gparted is Debian)

If not, does it make sense to try to create the USB drive using Gparted?

If that doesn't work I guess I could install Arch on a random computer and just hope it works well enough to do the install.

I guess my first question should have been: is there anything I can try short of reinstalling Arch?

Thanks for any help you can provide...
Posts: 15
Joined: Sat Jan 19, 2013 8:56 pm

Re: Can I unbrick it? (B01 won't boot/connect)

Postby WarheadsSE » Fri Jan 25, 2013 2:07 pm

Re-installing arch is cake.

- Boot back into that livecd
- Format the partition again
- Extract the downloaded rootfs onto it, as root (or sudo su)
- eject
- Stick in plug.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
Posts: 6807
Joined: Mon Oct 18, 2010 2:12 pm

Return to Community Supported

Who is online

Users browsing this forum: No registered users and 1 guest