no sound output...help me

This forum is for all other ARMv5 devices

no sound output...help me

Postby jihoon7975 » Mon Feb 04, 2013 2:41 am

I followed a former troubleshooting procedure and after running 'bash alsa.sh info' (or something like that) I got this result.
I would appreciate it if anyone could help me.

Code: Select all
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.61
!!################################
!!Script ran on: Mon Feb  4 01:44:19 UTC 2013

!!Linux Distribution
!!------------------
Arch Linux \r (\l) NAME="Arch Linux ARM" ID=archarm ID_LIKE=arch PRETTY_NAME="Arch Linux AR$

!!DMI Information
!!---------------
Manufacturer:
Product Name:
Product Version:
Firmware Version:

!!Kernel Information
!!------------------
Kernel release:    2.6.31.6_SMP_820
Operating System:  GNU/Linux
Architecture:      armv6l
Processor:         unknown
SMP Enabled:       Yes

!!ALSA Version
!!------------
Driver version:     1.0.20
Library version:    1.0.26
Utilities version:  1.0.26

!!Loaded ALSA modules
!!-------------------
snd_usb_audio
!!Sound Servers on this system
!!----------------------------
Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No

!!Soundcards recognised by ALSA
!!-----------------------------
0 [Audio          ]: USB-Audio - DigiHug USB Audio
                      FiiO DigiHug USB Audio at usb-usb-1.1, full speed

!!PCI Soundcards installed in the system
!!--------------------------------------


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------


!!Loaded sound module options
!!---------------------------
!!Module: snd_usb_audio
        async_unlink : Y
        device_setup : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
        enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
        id : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<$
        ignore_ctl_error : N
        index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,$
        nrpacks : 8
        pid : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1$
        vid : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1$

!!ALSA Device nodes
!!-----------------
crw-rw---- 1 root audio 116, 6 Dec 31  1969 /dev/snd/controlC0
crw-rw---- 1 root audio 116, 5 Dec 31  1969 /dev/snd/pcmC0D0c
crw-rw---- 1 root audio 116, 4 Dec 31  1969 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116, 3 Dec 31  1969 /dev/snd/pcmC0D1p
crw-rw---- 1 root audio 116, 2 Dec 31  1969 /dev/snd/timer
/dev/snd/by-id:
total 0
drwxr-xr-x 2 root root  60 Dec 31  1969 .
drwxr-xr-x 4 root root 180 Dec 31  1969 ..
lrwxrwxrwx 1 root root  12 Dec 31  1969 usb-FiiO_DigiHug_USB_Audio-01 -> ../controlC0
/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root  60 Dec 31  1969 .
drwxr-xr-x 4 root root 180 Dec 31  1969 ..
lrwxrwxrwx 1 root root  12 Dec 31  1969 platform-oxnas-ehci.0-usb-0:1.1:1.1 -> ../controlC0

!!Aplay/Arecord output
!!--------------------
APLAY
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [DigiHug USB Audio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [DigiHug USB Audio], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
ARECORD
**** List of CAPTURE Hardware Devices ****
card 0: Audio [DigiHug USB Audio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Audio]
amixer: Mixer load hw:0 error: Invalid argument
Card hw:0 'Audio'/'FiiO DigiHug USB Audio at usb-usb-1.1, full speed'
  Mixer name    : 'USB Mixer'
  Components    : 'USB1852:7022'
  Controls      : 2
amixer: Mixer hw:0 load error: Invalid argument

!!Alsactl output
!!--------------
--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------
Module
bootled_module
snd_usb_audio
snd_hwdep
snd_usb_lib
snd_pcm
snd_page_alloc
snd_rawmidi
snd_seq_device
snd_timer
snd
evdev
gmac
evbug
soundcore
mii

!!ALSA/HDA dmesg
!!--------------
jihoon7975
 
Posts: 1
Joined: Mon Feb 04, 2013 2:39 am

Return to Community Supported

Who is online

Users browsing this forum: No registered users and 1 guest