/dev/mtdblock* absent on QNAP TS-119 (kirkwood)

This forum is for all other ARMv5 devices

/dev/mtdblock* absent on QNAP TS-119 (kirkwood)

Postby shock » Tue Dec 02, 2014 6:47 pm

Hello,

I've taken the plunge and installed Arch LInux ARM on my QNAP TS-119 based on the tutorial at http://ramblings.silveira.ws/2014/03/in ... s-212.html (referenced in another topic in this forum), but after instalation there are no mtd devices available, which seems wrong because the tutorial explicitly mentions using the mtdblock2 device to flash a new kernel.

The flash is 16 MB STMicroelectronics 25P28V6P SPI and the specs for the nas are at http://www.cyrius.com/debian/kirkwood/q ... 119/specs/

I've also found this message at http://www.spinics.net/lists/arm-kernel/msg358760.html which mentions that modules spi-nor.ko and m25p80.ko needed to be manually loaded so I tried to do that but I couldn't find the modules.

At this point my guess is that support for this specific flash was dropped from the alarm kernel, what are my options? Do I need to compile my own kernel? I'd very much rather not do that if at all possible.

Thanks!
shock
 
Posts: 3
Joined: Tue Dec 02, 2014 5:43 pm

Re: /dev/mtdblock* absent on QNAP TS-119 (kirkwood)

Postby moonman » Tue Dec 02, 2014 10:11 pm

Yup looks like modules aren't included. I'll include them in the next releaae
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3089
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: /dev/mtdblock* absent on QNAP TS-119 (kirkwood)

Postby shock » Wed Dec 03, 2014 4:15 pm

Thanks a lot!

How can I tell when the new version has been released? At this point I've included "linux-kirkwood" in the IgnorePkgs pacman conf otherwise if I reboot there's a mismatch between the old kernel in flash and the new modules on the rootfs.

Would it be possible to get the old kernel/modules from March 2014, when it seems to have had the suport for my type of flash?
shock
 
Posts: 3
Joined: Tue Dec 02, 2014 5:43 pm

Re: /dev/mtdblock* absent on QNAP TS-119 (kirkwood)

Postby WarheadsSE » Wed Dec 03, 2014 5:18 pm

Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6727
Joined: Mon Oct 18, 2010 2:12 pm

Re: /dev/mtdblock* absent on QNAP TS-119 (kirkwood)

Postby moonman » Sun Dec 07, 2014 2:06 am

Done. 3.17.4-2 should be in the repos shortly
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3089
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: /dev/mtdblock* absent on QNAP TS-119 (kirkwood)

Postby shock » Tue Dec 16, 2014 9:30 pm

Thanks! My problem is fixed.
shock
 
Posts: 3
Joined: Tue Dec 02, 2014 5:43 pm


Return to Community Supported

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests