Perl CPAN and others won't run on bone stock install

This forum is for discussion about general software issues.

Perl CPAN and others won't run on bone stock install

Postby AndrewFritz » Tue Sep 18, 2018 6:06 am

I've got a older Seagate GoFlex Home. It has been running ArchLinux for a long time and all was good. I recently reinstalled fresh (format drive, copy image, etc). After the install the Perl install seems to be broken in a strange way.

I'm unable to run Cpan, nor can I manually install perl modules (ex: download tar.gz and run perl Makefile.pl, etc). I get the same problem related to MakeMaker from the core install:

Code: Select all
# cpan
Can't locate ExtUtils/MakeMaker/version/vpp.pm in @INC (you may need to install the ExtUtils::MakeMaker::version::vpp module) (@INC contains: /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 14) line 1.
BEGIN failed--compilation aborted at (eval 14) line 1.
Compilation failed in require at /usr/share/perl5/core_perl/ExtUtils/MakeMaker.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/core_perl/ExtUtils/MakeMaker.pm line 10.
Compilation failed in require at /usr/share/perl5/core_perl/CPAN.pm line 48.
BEGIN failed--compilation aborted at /usr/share/perl5/core_perl/CPAN.pm line 48.
Compilation failed in require at /usr/share/perl5/core_perl/App/Cpan.pm line 288.
BEGIN failed--compilation aborted at /usr/share/perl5/core_perl/App/Cpan.pm line 288.
Compilation failed in require at /usr/bin/core_perl/cpan line 10.
BEGIN failed--compilation aborted at /usr/bin/core_perl/cpan line 10.


The same error occurs when trying to manually install a perl module (perl Makefile.pl). My other ArchLinux Arm installs all work fine so this seems to be specific to Armv5 but I'm not sure. Google hasn't turned up anything other than various centos posts that just need to install ExtUtils::MakeMaker, which appears to be installed properly:

Code: Select all
[root@tank2 MakeMaker]# pwd
/usr/share/perl5/core_perl/ExtUtils/MakeMaker
[root@tank2 MakeMaker]# ls
Config.pm  FAQ.pod  Locale.pm  Tutorial.pod  version.pm
[root@tank2 MakeMaker]#


I've tried updating (pacman -Syyu) and also clearing my cache and reinstalling perl (pacman -Scc; packman -S perl).

It seems like something else is borked but I can't guess what. Any suggestions of where to dig would be appreciated.
AndrewFritz
 
Posts: 2
Joined: Tue Sep 18, 2018 5:55 am

Re: Perl CPAN and others won't run on bone stock install

Postby AndrewFritz » Tue Sep 18, 2018 6:17 am

On further investigation, it appears the perl modules I'm trying to install on this system through cpan are included with Archlinux by default on at least one of other of my arm based systems (a Pi3B+). It seems like maybe a bunch of dependencies got skipped on this system either one-off or in general on this older armv5?
AndrewFritz
 
Posts: 2
Joined: Tue Sep 18, 2018 5:55 am

Re: Perl CPAN and others won't run on bone stock install

Postby stasheck » Sat Oct 20, 2018 4:04 pm

Have you been able to fix this? It's driving me crazy :/
stasheck
 
Posts: 5
Joined: Wed Jun 29, 2016 7:24 am

Re: Perl CPAN and others won't run on bone stock install

Postby stelu » Thu Jan 03, 2019 2:48 pm

I'm struggling with the same issue, cpan fails. No one with similar troubles?
There is no bug report with "Can't locate ExtUtils/MakeMaker/version/vpp.pm". Perhaps I'll do this and I'll try to fall back to perl 5.26.
stelu
 
Posts: 4
Joined: Sun Nov 13, 2011 5:45 pm

Re: Perl CPAN and others won't run on bone stock install

Postby stelu » Sat Jan 05, 2019 10:52 am

At lease a downgrade is succesful "pacman -U /var/cache/pacman/pkg/perl-5.26.1-2-arm.tar.xz" .
Cpan is working again and my previously installed Device::SerialPort too :-) .
stelu
 
Posts: 4
Joined: Sun Nov 13, 2011 5:45 pm

Re: Perl CPAN and others won't run on bone stock install

Postby slowcoach » Thu Jan 24, 2019 5:12 pm

I've just hit this on my armv5tel machine which I hadn't updated for several months.
I suspect it needs to be brought to the attention of the Perl Porters to get it fixed. I'll have another look at their Bulletin Boards & post something there.
slowcoach
 
Posts: 3
Joined: Thu Jan 24, 2019 4:55 pm

Re: Perl CPAN and others won't run on bone stock install

Postby slowcoach » Tue Jan 29, 2019 10:52 pm

I've put this to Perl Porters and received a request that I apply a patch & report back on whether it fixes the problem:

"Can you apply the patch at https://perl5.git.perl.org/perl.git/pat ... 70dfb2fea2, and tell us if that solves your problem?"

Having struggled with it for some time I can't get it to work on a Perlbrew test setup. This is beyond my ability but if there's anyone on these forums who'd like to have a go at it you can find the ticket I opened at:

https://rt.perl.org/Ticket/Display.html?id=133803
slowcoach
 
Posts: 3
Joined: Thu Jan 24, 2019 4:55 pm

Re: Perl CPAN and others won't run on bone stock install

Postby slowcoach » Tue Feb 05, 2019 9:46 am

I discovered that patching a perlbrew installation was the wrong way to go.

I started following this guide instead:
https://forums.slimdevices.com/showthre ... -contained

I installed the patch and then configure ran OK. Make still failed so I've reported it back to perl porters.
slowcoach
 
Posts: 3
Joined: Thu Jan 24, 2019 4:55 pm


Return to General

Who is online

Users browsing this forum: No registered users and 2 guests