Cannot use Elan touchpad in XFCE.

This forum is for discussion about general software issues.

Cannot use Elan touchpad in XFCE.

Postby fastfastepic » Mon Jul 27, 2020 4:45 pm

Greetings,I am using a chromebook and I am dualbooting in arch linux ARM with a microSD, my chromebook's model is a lenovo C330, and my Elan Touchpad doesn't work.

Here's what I did to try to fix the problem:
1. I Installed libinput
2. I tried to use a custom configuration file in /etc/modprobe.d with the following " psmouse elantech_smbus= 0
psmouse synaptics_intertouch=0"
3. I tried to disable/ reenable my touchpad with "xinput enable"


Here's what libinput list-devices says about my Elan Touchpad:
Code: Select all
Device:    Elan Touchpad
Kernel: /dev/input/event2
Group: 4
Seat:  seat0,default
Size: 104x59mm
Capabilities: pointer gestures
Tap-to-click: disabled
Tap-and-drag: enabled
Tap drag lock: disabled
Left-handed: disabled
Nat.scrolling: disabled
Middle emulation: disabled
Calibration: n/a
Scroll methods: *two-finger edge
Click methods: *button-areas clickfinger
Disable-w-typing: enabled
Accel profiles: none
Rotation: n/a


If you need anything more, let me know!
fastfastepic
 
Posts: 1
Joined: Mon Jul 27, 2020 4:27 pm

Return to General

Who is online

Users browsing this forum: No registered users and 4 guests