tigervnc - starting headless sessions manually

This forum is for discussion about general software issues.

tigervnc - starting headless sessions manually

Postby andreworg » Sun Jan 31, 2021 6:56 pm

Hi all,
I'm having difficulties in starting headless X11 sessions via tigervnc.
I usually started my sessions by hand, lately by using dbus-launch. Everything worked like a charm for ages.
With the latest releases I'm having a lot of trouble. I cannot find a good way to run a session manually.
I tried with this script:

Code: Select all
#!/bin/bash
if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
  eval `dbus-launch --sh-syntax`
  echo "D-Bus per-session daemon address is: $DBUS_SESSION_BUS_ADDRESS"
fi
export DISPLAY=:2
Xvnc :2 -passwordfile ~/.vnc/passwd -localhost -nolisten tcp -geometry 1400x960 -depth 16 -nevershared &
xfce4-session &


It works only on one of my raspi3 units, only for one user (I need two different sessions running as different users).
On the other raspi3 units... xfce4-session even reboots the machine!
I even followed the instructions from https://wiki.archlinux.org/index.php/TigerVNC - same thing, the raspi reboots.

Darn!

EDIT:
The script works for both users - I was making a mistake during my tests.
The second raspi3 unit still reboots. Maybe it is a hardware problem.
andreworg
 
Posts: 8
Joined: Sat Jun 25, 2016 1:04 pm

Re: tigervnc - starting headless sessions manually

Postby andreworg » Mon Feb 15, 2021 3:15 pm

UPDATE:
after the latest package upgrade, the system no longer crashes.
These are the packages that have been upgraded:

Code: Select all
[2021-02-15T09:00:29+0000] [ALPM] upgraded util-linux-libs (2.36.1-4 -> 2.36.2-1)
[2021-02-15T09:00:29+0000] [ALPM] upgraded linux-api-headers (5.8-1 -> 5.10.13-1)
[2021-02-15T09:00:30+0000] [ALPM] upgraded iana-etc (20201229-1 -> 20210202-1)
[2021-02-15T09:00:30+0000] [ALPM] upgraded glib2 (2.66.4-2 -> 2.66.7-1)
[2021-02-15T09:00:31+0000] [ALPM] upgraded pango (1:1.48.1-1 -> 1:1.48.2-1)
[2021-02-15T09:00:31+0000] [ALPM] upgraded json-glib (1.6.0-1 -> 1.6.2-1)
[2021-02-15T09:00:31+0000] [ALPM] upgraded gtk-update-icon-cache (1:4.0.2-1 -> 1:4.0.3-1)
[2021-02-15T09:00:31+0000] [ALPM] upgraded e2fsprogs (1.46.0-1 -> 1.46.1-1)
[2021-02-15T09:00:31+0000] [ALPM] upgraded libcap (2.47-1 -> 2.48-1)
[2021-02-15T09:00:32+0000] [ALPM] upgraded gdbm (1.19-1 -> 1.19-2)
[2021-02-15T09:00:32+0000] [ALPM] upgraded lcms2 (2.11-2 -> 2.12-1)
[2021-02-15T09:00:32+0000] [ALPM] upgraded device-mapper (2.02.187-3 -> 2.03.11-4)
[2021-02-15T09:00:32+0000] [ALPM] upgraded cryptsetup (2.3.4-1 -> 2.3.4-2)
[2021-02-15T09:00:32+0000] [ALPM] upgraded hwids (20200813.1-1 -> 20201207-1)
[2021-02-15T09:00:33+0000] [ALPM] upgraded util-linux (2.36.1-4 -> 2.36.2-1)
[2021-02-15T09:00:33+0000] [ALPM] upgraded findutils (4.7.0-2 -> 4.8.0-1)
[2021-02-15T09:00:37+0000] [ALPM] upgraded js78 (78.7.0-1 -> 78.7.1-1)
[2021-02-15T09:00:37+0000] [ALPM] upgraded vulkan-icd-loader (1.2.166-1 -> 1.2.169-1)
[2021-02-15T09:00:42+0000] [ALPM] upgraded perl (5.32.0-3 -> 5.32.1-1)
[2021-02-15T09:00:47+0000] [ALPM] upgraded gtk3 (1:3.24.24-2 -> 1:3.24.25-1)
[2021-02-15T09:00:47+0000] [ALPM] upgraded dav1d (0.8.1-1 -> 0.8.1-2)
[2021-02-15T09:00:48+0000] [ALPM] upgraded libsndfile (1.0.28-3 -> 1.0.31-1)
[2021-02-15T09:00:48+0000] [ALPM] upgraded libsamplerate (0.1.9-3 -> 0.2.1-1)
[2021-02-15T09:01:03+0000] [ALPM] upgraded chromium (88.0.4324.146-2 -> 88.0.4324.150-1)
[2021-02-15T09:01:22+0000] [ALPM] upgraded firefox (85.0-1 -> 85.0.2-1)
[2021-02-15T09:01:23+0000] [ALPM] upgraded graphene (1.10.2-1 -> 1.10.4-1)
[2021-02-15T09:01:23+0000] [ALPM] upgraded libassuan (2.5.4-1 -> 2.5.4-2)
[2021-02-15T09:01:23+0000] [ALPM] upgraded libburn (1.5.2-2 -> 1.5.4-1)
[2021-02-15T09:01:23+0000] [ALPM] upgraded libisofs (1.5.2-2 -> 1.5.4-1)
[2021-02-15T09:02:17+0000] [ALPM] upgraded linux-firmware (20201218.646f159-1 -> 20210208.b79d239-1)
[2021-02-15T09:02:30+0000] [ALPM] upgraded linux-raspberrypi (5.10.13-1 -> 5.10.14-2)
[2021-02-15T09:02:31+0000] [ALPM] upgraded man-db (2.9.3-1 -> 2.9.4-1)
[2021-02-15T09:02:31+0000] [ALPM] upgraded npth (1.6-2 -> 1.6-3)
[2021-02-15T09:02:32+0000] [ALPM] upgraded pacman (5.2.2-1 -> 5.2.2-2)
[2021-02-15T09:02:32+0000] [ALPM] upgraded psmisc (23.3-4 -> 23.4-1)
[2021-02-15T09:02:36+0000] [ALPM] upgraded python (3.9.1-1 -> 3.9.1-2)
[2021-02-15T09:02:44+0000] [ALPM] upgraded qt5-base (5.15.2-3 -> 5.15.2-5)
[2021-02-15T09:02:46+0000] [ALPM] upgraded raspberrypi-bootloader (20210128-1 -> 20210208-1)
[2021-02-15T09:02:47+0000] [ALPM] upgraded raspberrypi-bootloader-x (20210128-1 -> 20210208-1)
[2021-02-15T09:02:50+0000] [ALPM] upgraded raspberrypi-firmware (20210128-1 -> 20210128-2)
[2021-02-15T09:02:50+0000] [ALPM] upgraded stress (1.0.4-5 -> 1.0.4-6)
[2021-02-15T09:02:51+0000] [ALPM] upgraded thunar (4.16.2-1 -> 4.16.3-1)
[2021-02-15T09:02:59+0000] [ALPM] upgraded vim-runtime (8.2.2380-1 -> 8.2.2489-1)
[2021-02-15T09:02:59+0000] [ALPM] upgraded vim (8.2.2380-1 -> 8.2.2489-1)
[2021-02-15T09:02:59+0000] [ALPM] upgraded vte-common (0.62.2-1 -> 0.62.3-1)
[2021-02-15T09:03:00+0000] [ALPM] upgraded vte3 (0.62.2-1 -> 0.62.3-1)
[2021-02-15T09:03:00+0000] [ALPM] upgraded wpa_supplicant (2:2.9-7 -> 2:2.9-8)
[2021-02-15T09:03:00+0000] [ALPM] upgraded xfce4-cpugraph-plugin (1.2.1-1 -> 1.2.2-1)
[2021-02-15T09:03:00+0000] [ALPM] upgraded xfce4-power-manager (4.16.0-1 -> 4.16.0-2)
[2021-02-15T09:03:01+0000] [ALPM] upgraded xfce4-taskmanager (1.4.0-2 -> 1.4.2-1)
[2021-02-15T09:03:01+0000] [ALPM] upgraded xfce4-weather-plugin (0.10.2-1 -> 0.11.0-1)


Anybody care to take a guess? :D
andreworg
 
Posts: 8
Joined: Sat Jun 25, 2016 1:04 pm


Return to General

Who is online

Users browsing this forum: No registered users and 3 guests