X window not booting

This forum is for discussion about general software issues.

X window not booting

Postby gcao » Fri Mar 15, 2024 8:40 pm

Hello!

The problem suddenly popped up from yesterday on the RPi4, and when running `startx`, it complainted as

```
(EE)
(EE) Backtrace:
xinit: giving up
xinit: unable to conect to X server: Connection refused
xinit l server error
```

I cleaned up everything in `xinitrc` except `exec dwm`, as well as re-installed the entire system, but the problem remains.. I wonder if there is a new kernel release for armv7l or package upgrade that interferes with it. Thanks for your help!
gcao
 
Posts: 3
Joined: Fri Mar 15, 2024 8:24 pm

Re: X window not booting

Postby gcao » Sat Mar 16, 2024 2:11 pm

... and I am using `linux-rpi 6.6.21-2` on armv7h. According the webpage below, an update was made on Mar 13.

`https://archlinuxarm.org/packages/armv7h/linux-rpi`
gcao
 
Posts: 3
Joined: Fri Mar 15, 2024 8:24 pm

Re: X window not booting

Postby m040601 » Wed Mar 20, 2024 11:37 am

make_clickable_callback(MAGIC_URL_FULL, '', 'http://0x0.st/XrOe.txt', '', ' class="postlink"')
m040601
 
Posts: 28
Joined: Tue Jan 28, 2020 6:36 pm

Re: X window not booting

Postby m040601 » Wed Mar 20, 2024 11:42 am

I have the exact same error message or Raspberry Pi 2 (armv7)

I cannot post my full text.

This PHP forum software is broken.

This is the link,make_clickable_callback(MAGIC_URL_FULL, ' ', 'http://0x0.st/XrOe.txt.', '', ' class="postlink"')


```make_clickable_callback(MAGIC_URL_FULL, '
', 'http://0x0.st/XrOe.txt', '', ' class="postlink"')
```


Do you also see coredumps of Xorg and libunwind in the journalctl ?
m040601
 
Posts: 28
Joined: Tue Jan 28, 2020 6:36 pm

Re: X window not booting

Postby rern » Wed Mar 20, 2024 1:05 pm

On armv7h, it's libunwind 1.8.1. Downgrading to 1.7.2 should resolve the issue.

wget https://alaa.ad24.cz/packages/l/libunwind/libunwind-1.7.2-1-armv7h.pkg.tar.xz
pacman -U libunwind-1.7.2-1-armv7h.pkg.tar.xz
rern
 
Posts: 3
Joined: Sat Jan 01, 2022 11:44 am

Re: X window not booting

Postby gcao » Fri Mar 22, 2024 8:44 pm

Thanks @m040601 for providing the detailed logs and I confirm to share the same issue.

Thanks @rern for showing a solution, and I confirm downgrading `libunwind` works for starting X windows.
gcao
 
Posts: 3
Joined: Fri Mar 15, 2024 8:24 pm

Re: X window not booting

Postby coolgoose1 » Wed Apr 03, 2024 12:55 pm

Had the same issue upgrading xf86-video-fbdev (0.5.0-3 -> 0.5.0-4), with or without libunwind (1.7.2-1 -> 1.8.1-1).

Downgrade to 0.5.0-3 brings X back.
coolgoose1
 
Posts: 9
Joined: Mon Nov 09, 2020 3:27 am

Re: X window not booting

Postby micks » Sat May 04, 2024 10:52 am

Hello everyone. :)

I have the same error. But I am missing the two packages (just installed today) for a downgrade. Is there still a way to get them? They are no longer on the mirrors.

best regards
micks
micks
 
Posts: 1
Joined: Sat May 04, 2024 10:46 am

Re: X window not booting

Postby coolgoose1 » Tue May 21, 2024 11:54 am

[quote="micks"]Hello everyone. :)

I have the same error. But I am missing the two packages (just installed today) for a downgrade. Is there still a way to get them? They are no longer on the mirrors.

best regards
micks[/quote]
Sorry for the late response, did not see this earlier. I do have a copy of the packages if you still need them.
coolgoose1
 
Posts: 9
Joined: Mon Nov 09, 2020 3:27 am


Return to General

Who is online

Users browsing this forum: No registered users and 4 guests

cron