error when install gitlab

This forum is for discussion about general software issues.

error when install gitlab

Postby gcd0318 » Sun Sep 11, 2016 7:19 pm

I tried to install gitlab by pacman:
Code: Select all
pacman -S gitlab

and got following error:
Code: Select all
resolving dependencies...
warning: cannot resolve "ruby2.1", a dependency of "gitlab"
warning: cannot resolve "ruby2.1-bundler", a dependency of "gitlab"
:: The following package cannot be upgraded due to unresolvable dependencies:
      gitlab

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: gitlab: requires ruby2.1
:: gitlab: requires ruby2.1-bundler

It seems no package as ruby2.1. I also installed ruby v2.1.8 by rvm, and
Code: Select all
rvm use 2.1

But I got the same error as above
Anyone can help? thanks in advance
gcd0318
 
Posts: 15
Joined: Tue Feb 10, 2015 2:14 pm

Re: error when install gitlab

Postby WarheadsSE » Mon Sep 12, 2016 4:25 pm

On which platform?
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6799
Joined: Mon Oct 18, 2010 2:12 pm

Re: error when install gitlab

Postby Markos » Sat Oct 15, 2016 4:38 pm

Hi, same problem here.

Platform=ARMv7
Markos
 
Posts: 1
Joined: Sat Oct 15, 2016 4:36 pm

Re: error when install gitlab

Postby WarheadsSE » Sun Oct 16, 2016 4:59 pm

I'm looking into it. For now, as it turns out, there is a problem with unf_ext gem for the gitlab package, thus the package is out of date for the repo at the moment.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6799
Joined: Mon Oct 18, 2010 2:12 pm

Re: error when install gitlab

Postby WarheadsSE » Sun Oct 16, 2016 6:25 pm

Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6799
Joined: Mon Oct 18, 2010 2:12 pm

Re: error when install gitlab

Postby Nordseebaer » Thu Nov 03, 2016 10:00 am

Hi,

i've got the same problem. Is there a way to solve this manually? (I'm an arch beginner)

Thanks in advance
Nordseebaer
 
Posts: 1
Joined: Thu Nov 03, 2016 9:57 am

Re: error when install gitlab

Postby WarheadsSE » Thu Nov 03, 2016 3:45 pm

While we wait on a properly tagged version of the affected library in ruby, you may be stuck with an older version. You could investigate the omnibus-gitlab package for raspbian, to be converted to an Arch package.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6799
Joined: Mon Oct 18, 2010 2:12 pm

Re: error when install gitlab

Postby bulletmark » Mon Nov 07, 2016 10:54 pm

Gitlab is a resource hog and a pain to install and manage. I switched to Gogs which is a piece of cake to install and much lighter on resources.
bulletmark
 
Posts: 40
Joined: Tue Oct 13, 2015 10:17 pm

Re: error when install gitlab

Postby WarheadsSE » Tue Nov 08, 2016 12:14 pm

Gogs is Go Git Service, written in golang.

Combine being a fully compiled (as compared to Ruby) program, and a reduced feature set, it is currently able to operate in lower performance, and more constrained environment.

GitLab can be heavy at times, and they are aware of this. To this end, they actually employ a maintainer of gogs, to maintain gogs and the import export layer between GitLab and gogs.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6799
Joined: Mon Oct 18, 2010 2:12 pm


Return to General

Who is online

Users browsing this forum: No registered users and 2 guests