Intel 3160 on ClearFog (marvell)

This forum is for discussion about general software issues.

Intel 3160 on ClearFog (marvell)

Postby djsumdog » Sat Oct 08, 2016 6:21 pm

So I've got a ClearFog Pro running Arch using the official latest image in the wiki. I've done a full update with pacman, rebooted it, and still get the following when the kernel tries to initialize my Intel 3160 miniPCIE card:

Code: Select all
[  512.973436] Intel(R) Wireless WiFi driver for Linux
[  512.978347] Copyright(c) 2003- 2015 Intel Corporation
[  512.986975] iwlwifi 0000:02:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
[  513.002979] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0xFFFFFFFF
[  513.011678] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[  513.034620] ------------[ cut here ]------------
[  513.039259] WARNING: CPU: 1 PID: 2771 at drivers/net/wireless/iwlwifi/pcie/trans.c:1552 iwl_trans_pcie_grab_nic_access+0x118/0x124 [iwlwifi]()
[  513.052066] Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
[  513.058867] Modules linked in: iwlmvm(+) iwlwifi mac80211 btusb btrtl btbcm cfg80211 btintel bluetooth rfkill marvell_cesa des_generic sch_fq_codel ip_tables x_tables autofs4 [last unloaded: iwlwifi]
[  513.076821] CPU: 1 PID: 2771 Comm: modprobe Tainted: G        W       4.4.23-2-ARCH #1
[  513.084754] Hardware name: Marvell Armada 380/385 (Device Tree)
[  513.090696] [<c0017b64>] (unwind_backtrace) from [<c0013264>] (show_stack+0x10/0x14)
[  513.098460] [<c0013264>] (show_stack) from [<c038bc9c>] (dump_stack+0x84/0x98)
[  513.105701] [<c038bc9c>] (dump_stack) from [<c002917c>] (warn_slowpath_common+0x80/0xb0)
[  513.113811] [<c002917c>] (warn_slowpath_common) from [<c00291dc>] (warn_slowpath_fmt+0x30/0x40)
[  513.122535] [<c00291dc>] (warn_slowpath_fmt) from [<bf2591b8>] (iwl_trans_pcie_grab_nic_access+0x118/0x124 [iwlwifi])
[  513.133182] [<bf2591b8>] (iwl_trans_pcie_grab_nic_access [iwlwifi]) from [<bf24e20c>] (iwl_read_prph+0x24/0x78 [iwlwifi])
[  513.144172] [<bf24e20c>] (iwl_read_prph [iwlwifi]) from [<bf2587b8>] (iwl_pcie_apm_init+0x22c/0x278 [iwlwifi])
[  513.154207] [<bf2587b8>] (iwl_pcie_apm_init [iwlwifi]) from [<bf25ba34>] (iwl_trans_pcie_start_hw+0x50/0xe0 [iwlwifi])
[  513.164971] [<bf25ba34>] (iwl_trans_pcie_start_hw [iwlwifi]) from [<bf27d7a0>] (iwl_op_mode_mvm_start+0x490/0x6a8 [iwlmvm])
[  513.176166] [<bf27d7a0>] (iwl_op_mode_mvm_start [iwlmvm]) from [<bf24e938>] (iwl_opmode_register+0x84/0xcc [iwlwifi])
[  513.186839] [<bf24e938>] (iwl_opmode_register [iwlwifi]) from [<bf2a2034>] (iwl_mvm_init+0x34/0x5c [iwlmvm])
[  513.196724] [<bf2a2034>] (iwl_mvm_init [iwlmvm]) from [<c000985c>] (do_one_initcall+0x90/0x1d4)
[  513.205445] [<c000985c>] (do_one_initcall) from [<c00bd9cc>] (do_init_module+0x60/0x374)
[  513.213556] [<c00bd9cc>] (do_init_module) from [<c0096cb8>] (load_module+0x1a58/0x1fd4)
[  513.221581] [<c0096cb8>] (load_module) from [<c009737c>] (SyS_init_module+0x148/0x160)
[  513.229517] [<c009737c>] (SyS_init_module) from [<c000f580>] (ret_fast_syscall+0x0/0x1c)
[  513.237624] ---[ end trace 71ba1aa822557891 ]---
[  513.362979] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[  519.385699] iwlwifi 0000:02:00.0: Failed to load firmware chunk!


I've tried rmmod/modproble on the iwlwifif driver, but still get a firmware loading error in my dmesg.

Has anyone had issues with the Intel drivers/firmware on this architecture?
djsumdog
 
Posts: 9
Joined: Tue Oct 04, 2016 8:22 pm

Re: Intel 3160 on ClearFog (marvell)

Postby moonman » Sun Oct 09, 2016 8:05 am

Try the official images for clearfog and see if they have the same problem. If they do then it must be something either with the sources or some weird incompatibility. I only tested atheros n mini pcie in mine as i don't have anything else
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3077
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Intel 3160 on ClearFog (marvell)

Postby djsumdog » Sun Oct 16, 2016 5:20 am

Clearfog's Debian image does the same thing. Also on both, the bluetooth goes into an endless loop of reloading the Intel BT module; fills up the kernel logs. :-/

I attempted a BCM4352 as well, but it turns out there's no ARM/proprietary driver support for that chip (and the OSS drivers don't support it either).

What's the exact Atheros chip in your Wi-Fi card? If I buy something else, I want to know it will actually work.
djsumdog
 
Posts: 9
Joined: Tue Oct 04, 2016 8:22 pm


Return to General

Who is online

Users browsing this forum: No registered users and 4 guests