Yubikey scdaemon udev rules not found

This forum is for discussion about general software issues.

Yubikey scdaemon udev rules not found

Postby ramsey » Wed Aug 16, 2017 3:53 am

Hi everyone,

I've installed Arch on a Samsung Chromebook Plus, and I'm really enjoying it. One bump in the road I've run into is getting my yubikeys to work. If I did a gpg --card-status, I'd get an error message

Code: Select all
$ gpg --card-status           
gpg: selecting openpgp failed: No such device
gpg: OpenPGP card not available: No such device


With gpg --card-status --debug-all

Code: Select all
$ gpg --card-status --debug-all
gpg: Note: no default option file '/home/alarm/.gnupg/gpg.conf'
gpg: enabled debug flags: packet mpi crypto filter iobuf memory cache memstat trust hashing ipc clock lookup extprog
gpg: DBG: [not enabled in the source] start
gpg: DBG: chan_3 <- OK Pleased to meet you, process 6528
gpg: DBG: connection to agent established
gpg: DBG: chan_3 -> RESET
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION ttyname=/dev/pts/0
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION ttytype=xterm-256color
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION display=:0.0
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION xauthority=/home/alarm/.Xauthority
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION putenv=DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION lc-ctype=C
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION lc-messages=C
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> GETINFO version
gpg: DBG: chan_3 <- D 2.1.23
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION allow-pinentry-notify
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> OPTION agent-awareness=2.1.0
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> SCD GETINFO version
gpg: DBG: chan_3 <- D 2.1.23
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> SCD SERIALNO openpgp
gpg: DBG: chan_3 <- ERR 100696144 No such device <SCD>
gpg: selecting openpgp failed: No such device
gpg: OpenPGP card not available: No such device
gpg: DBG: [not enabled in the source] stop
gpg: keydb: handles=0 locks=0 parse=0 get=0
gpg:        build=0 update=0 insert=0 delete=0
gpg:        reset=0 found=0 not=0 cache=0 not=0
gpg: kid_not_found_cache: count=0 peak=0 flushes=0
gpg: sig_cache: total=0 cached=0 good=0 bad=0
gpg: random usage: poolsize=600 mixed=0 polls=0/0 added=0/0
              outmix=0 getlvl1=0/0 getlvl2=0/0
gpg: secmem usage: 0/32768 bytes in 0 blocks


I discovered, that I need to add udev rules to fix this.

lsusb tells me

Bus 005 Device 002: ID 1050:0407 Yubico.com Yubikey 4 OTP+U2F+CCID

So if I add a file /etc/udev/rules.d/yubikey.rules containing:

Code: Select all
ATTRS{idVendor}=="1050", ATTRS{idProduct}=="0407", MODE="664", GROUP="alarm"


Then gpg works again. It seems in the other forum, udev rules were added for scdaemon in the GPG distribution for debian. Is that something that can be done for Arch as well? It would be nice if this worked without any additional fiddling.

Sorry if the message is a bit long. I'm hoping that helps others find it, as this was the first place I searched and I had no luck.

Thanks
ramsey
 
Posts: 3
Joined: Mon Aug 14, 2017 3:46 pm

Return to General

Who is online

Users browsing this forum: No registered users and 4 guests