bluez 5.47 rfcomm without legacy tools

This forum is for discussion about general software issues.

bluez 5.47 rfcomm without legacy tools

Postby lennylennard » Wed Sep 27, 2017 7:14 pm

hello!
i am trying to connect and communicate to a HC-05 module.
raspberry pi 3 bluetooth <-> hc-05

however since many of the old tools from the bluez4 era are deprecated i only want to use
the tools provided from bluez-utils 5.47-2

what i did so far starting from a fresh installation:
Code: Select all
pacman -Syu
reboot...
pacman -S firmware-raspberrypi
pacman -S bluez bluez-utils
pacman -S rfkill
reboot...
modprobe bluetooth
modprobe btbcm
systemctl start bluetooth


Code: Select all
systemctl status bluetooth
* bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2017-09-27 18:38:37 UTC; 3s ago
     Docs: man:bluetoothd(8)
 Main PID: 415 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           `-415 /usr/lib/bluetooth/bluetoothd

Sep 27 18:38:37 rpi3 systemd[1]: Starting Bluetooth service...
Sep 27 18:38:37 rpi3 bluetoothd[415]: Bluetooth daemon 5.47
Sep 27 18:38:37 rpi3 systemd[1]: Started Bluetooth service.
Sep 27 18:38:37 rpi3 bluetoothd[415]: Starting SDP server
Sep 27 18:38:37 rpi3 bluetoothd[415]: Bluetooth management interface 1.14 initialized


Code: Select all
btattach -B /dev/ttyAMA0 -P bcm -N

Attaching Primary controller to /dev/ttyAMA0
Switched line discipline from 0 to 15
Device index 0 attached


Code: Select all
rfkill list
0: phy0: Wireless LAN
        Soft blocked: no                                                                                                                                                                                         
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no


dmesg shows:
Code: Select all
Bluetooth: hci0 command 0xfc45 tx timeout
Bluetooth: hci0: BCM: failed to write clock (-110)
Bluetooth: hci0 command 0x0c03 tx timeout
Bluetooth: hci0: BCM: Reset failed (-110)


also bluetoothctl shows me no devices

...and this is pretty much where i am at :/
has anyone done this before?
any hints? any ideas?
lennylennard
 
Posts: 1
Joined: Wed Sep 27, 2017 5:21 pm

Return to General

Who is online

Users browsing this forum: No registered users and 1 guest