OpenVPN Client will not connect after upgrade

This forum is for topics dealing with problems with software specifically in the ARMv5 repo.

OpenVPN Client will not connect after upgrade

Postby apowell656 » Sat Dec 30, 2017 2:42 am

Recently did a full system upgrade (Linux 4.4.63-1-ARCH on armv5tel) and this is the output that I am receiving when using the following command:
openvpn /etc/openvpn/client/client.conf

I have checked Google with no luck and have done multiple reboots. Any help would be appreciated.

Andre



Code: Select all
Fri Dec 29 21:33:41 2017 OpenVPN 2.4.4 armv5tel-unknown-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Sep 28 2017
Fri Dec 29 21:33:41 2017 library versions: OpenSSL 1.1.0g  2 Nov 2017, LZO 2.10
Fri Dec 29 21:33:41 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]216.151.180.3:1194
Fri Dec 29 21:33:41 2017 Socket Buffers: R=[163840->163840] S=[163840->163840]
Fri Dec 29 21:33:41 2017 UDP link local: (not bound)
Fri Dec 29 21:33:41 2017 UDP link remote: [AF_INET]216.151.180.3:1194
Fri Dec 29 21:33:41 2017 TLS: Initial packet from [AF_INET]216.151.180.3:1194, sid=1b1f3867 700e06c6
Fri Dec 29 21:33:41 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Fri Dec 29 21:33:41 2017 VERIFY OK: depth=1, C=US, ST=VPN, L=VPN, O=VPN, OU=VPN, CN=VPN, name=VPN, emailAddress=VPN
Fri Dec 29 21:33:41 2017 VERIFY KU OK
Fri Dec 29 21:33:41 2017 Validating certificate extended key usage
Fri Dec 29 21:33:41 2017 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Fri Dec 29 21:33:41 2017 VERIFY EKU OK
Fri Dec 29 21:33:41 2017 VERIFY OK: depth=0, C=US, ST=VPN, L=VPN, O=VPN, OU=VPN, CN=vpn, name=VPN
Fri Dec 29 21:33:42 2017 Control Channel: TLSv1.2, cipher TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
Fri Dec 29 21:33:42 2017 [vpn] Peer Connection Initiated with [AF_INET]216.151.180.3:1194
Fri Dec 29 21:33:43 2017 SENT CONTROL [vpn]: 'PUSH_REQUEST' (status=1)
Fri Dec 29 21:33:43 2017 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 198.18.0.1,dhcp-option DNS 198.18.0.2,rcvbuf 262144,explicit-exit-notify 5,route-gateway 172.21.92.1,topology subnet,ping 20,ping-restart 40,ifconfig 172.21.92.23 255.255.254.0,peer-id 5,cipher AES-256-GCM'
Fri Dec 29 21:33:43 2017 Option 'explicit-exit-notify' in [PUSH-OPTIONS]:5 is ignored by previous <connection> blocks
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: timers and/or timeouts modified
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: explicit notify parm(s) modified
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: --sndbuf/--rcvbuf options modified
Fri Dec 29 21:33:43 2017 Socket Buffers: R=[163840->327680] S=[163840->163840]
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: --ifconfig/up options modified
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: route options modified
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: route-related options modified
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: peer-id set
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: adjusting link_mtu to 1625
Fri Dec 29 21:33:43 2017 OPTIONS IMPORT: data channel crypto options modified
Fri Dec 29 21:33:43 2017 Data Channel: using negotiated cipher 'AES-256-GCM'
Fri Dec 29 21:33:43 2017 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Fri Dec 29 21:33:43 2017 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Fri Dec 29 21:33:43 2017 ROUTE_GATEWAY 192.168.1.254/255.255.255.0 IFACE=eth0 HWADDR=00:25:31:04:ba:f1
Fri Dec 29 21:33:43 2017 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
Fri Dec 29 21:33:43 2017 Exiting due to fatal error

apowell656
 
Posts: 40
Joined: Fri Jan 25, 2013 1:24 am

Re: OpenVPN Client will not connect after upgrade

Postby andre » Sat Dec 30, 2017 10:32 am

From the line
Code: Select all
Fri Dec 29 21:33:43 2017 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)

I would say the tun module isn't loaded.

try
Code: Select all
modprobe tun
andre
 
Posts: 53
Joined: Wed Jan 25, 2012 1:39 pm
Location: Eindhoven

Re: OpenVPN Client will not connect after upgrade

Postby apowell656 » Sat Dec 30, 2017 1:45 pm

Super cool - we share the same name, small world. I gave that a shot to no avail
Code: Select all
[owner@downloader ~]$ modprobe tun
modprobe: FATAL: Module tun not found in directory /lib/modules/4.4.63-1-ARCH


which led me to this https://superuser.com/questions/497245/ ... e-in-linux with the following output:

Code: Select all
[owner@downloader ~]$ find /lib/modules/ -iname 'tun.ko.gz'
/lib/modules/3.1.10-35-ARCH/kernel/drivers/net/tun.ko.gz
[owner@downloader ~]$ insmod /lib/modules/3.1.10-35-ARCH/kernel/drivers/net/tun.ko.gz
insmod: ERROR: could not insert module /lib/modules/3.1.10-35-ARCH/kernel/drivers/net/tun.ko.gz: Operation not permitted
[owner@downloader ~]$ sudo insmod /lib/modules/3.1.10-35-ARCH/kernel/drivers/net/tun.ko.gz
insmod: ERROR: could not insert module /lib/modules/3.1.10-35-ARCH/kernel/drivers/net/tun.ko.gz: Invalid module format


Any thoughts?
apowell656
 
Posts: 40
Joined: Fri Jan 25, 2013 1:24 am

Re: OpenVPN Client will not connect after upgrade

Postby andre » Sat Dec 30, 2017 10:51 pm

The module is compressed (.ko.gz)
I believe insmod only works with uncompressed modules. So, if you're trying to use insmod, you should uncompress it with gunzip and then insmod the .ko file. When you do this, I suggest making a copy of the file.

I suppose to make modprobe work you should run depmod. It should have been done automatically when upgrading the kernel, but it seems for some reason this hasn't been done correctly.
andre
 
Posts: 53
Joined: Wed Jan 25, 2012 1:39 pm
Location: Eindhoven

Re: OpenVPN Client will not connect after upgrade

Postby WarheadsSE » Sun Dec 31, 2017 3:15 am

His kernel modules don't align to the veraions
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6753
Joined: Mon Oct 18, 2010 2:12 pm

Re: OpenVPN Client will not connect after upgrade

Postby apowell656 » Sat Jan 06, 2018 10:13 pm

Thanks for the help, but I ended up just reinstalling the OS.

Andre
apowell656
 
Posts: 40
Joined: Fri Jan 25, 2013 1:24 am


Return to ARMv5

Who is online

Users browsing this forum: No registered users and 1 guest

cron