Any chance for restoring my bricked Goflex Home?

This forum is for topics dealing with problems with software specifically in the ARMv5 repo.

Any chance for restoring my bricked Goflex Home?

Postby ouchyoung » Wed Nov 09, 2016 11:55 am

Thank you for your attention and please forgive my poor English.

I installed ArchLinux ARM on my goflex home, well, it ran well but it's slower and slower recently, so I wanted to go back to the stock firmware. I followed the instructions from doozan.com as the following:

cd /tmp
wget http://projects.doozan.com/uboot/install_uboot_mtd0.sh
chmod +x install_uboot_mtd0.sh
./install_uboot_mtd0.sh

However, on the last step, it stopped and warned me that the code of the Uboot doesn't meet with that of Goflex Home, so I used another way as this:

wget http://goflex.scottn.us/uboot-mtd0-orig-goflexhome.kwb
flash_erase /dev/mtd0 0 4
nandwrite /dev/mtd0 uboot-mtd0-orig-goflexhome.kwb

After that, it reported the nand was successfully flashed. Then I re-ran the ./install_uboot_mtd0.sh and it went through without any problem and reported information for success. So I typed reboot to reboot my Goflex Home, but it never booted again, nor registered any IP on my router. I tried to listen on 10.10.10.5 6666, as well as 10.10.10.2 and 10.10.10.4 with a Macbook, but got nothing at all.

I also created a USB disk with the latest rootfs (Debian-4.4.0-kirkwood-tld-1-rootfs-bodhi.tar.bz2), after plugged in the USB disk, the front light went off, but there was still no registration of the device on my router.

So, is there any chance for restoring my device back? Thank you!
ouchyoung
 
Posts: 18
Joined: Fri May 10, 2013 5:26 pm

Re: Any chance for restoring my bricked Goflex Home?

Postby summers » Thu Nov 17, 2016 4:09 pm

Its not a machine I have, so I can only give general comments.

Machines that you have played about with the boor loader, as you have, its a question of if the boot loader works.

Hopefully you have a working version of uboot on the machine, but it is failing to boot the machine.

So most flexable option would be to find the UART headers on the board (so you'll need to open the box). Don't know if pin headers are their by deault, if they aren't you will need to get one soldered on. Then you'll need to plug in a serial cable, probably a 3.3V cable. Then fire up a serial browser on another machine, see if you can interrupt uboot - and then check what is wrong.

You may be able to fix, but if not write an OS to a USB stick, then work out the uboot commands to boot from the usb stick (basically fine the kernel on the stick, load it to memory, and then run it with the right command line to fine the root filesystem).

A bit of googling, and you should be able to find the UART header on the Goflex home, seem a few people that have connected it up, and supply pictures.

Alas without doing all this, it depends on how functional your uboot is, and thats hard to find out if it isn't booting ...

Hope this helps.
summers
 
Posts: 177
Joined: Sat Sep 06, 2014 12:56 pm


Return to ARMv5

Who is online

Users browsing this forum: No registered users and 1 guest