Does a nodejs version > 0.10.36 work for anyone on armv5?

This forum is for topics dealing with problems with software specifically in the ARMv5 repo.

Does a nodejs version > 0.10.36 work for anyone on armv5?

Postby wobble » Sat May 20, 2017 5:53 pm

I run nodejs on my pogoplug e02 but all versions > 0.10.36 that I tried always segfaulted for me. I didn't care too much because that version worked for me so I just didn't upgrade.

Now I would like to use some of node's newer features so I looked into this again.

With the current nodejs-7.10.0 this is what I get when running in gdb:

Code: Select all
Reading symbols from node...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/node
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0xb6ffc450 (LWP 26551)]
[New Thread 0xb4c8c450 (LWP 26552)]
[New Thread 0xb448c450 (LWP 26553)]
[New Thread 0xb3c8c450 (LWP 26554)]
[New Thread 0xb348c450 (LWP 26555)]

Thread 1 "node" received signal SIGSEGV, Segmentation fault.
0x0081ea98 in v8::internal::Code::CopyFrom(v8::internal::CodeDesc const&) ()


Which seems to be the same problem mentioned in this post from June 2015 regarding node 0.12.4 which was unfortunately never answered.

There is also this post from Feb 2015 which offers the plausible explanation that v8 dropped support for armv5 for the versions used in node > 0.10.

I would be willing to accept that it can't work, I just wonder why there are still packages for armv5 made after all this time. Plus, from what I found the effect of the dropped support in v8 seems to be that it doesn't compile which clearly seems to be solved.

Is there any hope for running current node on armv5?
wobble
 
Posts: 30
Joined: Fri Dec 04, 2015 2:15 pm

Return to ARMv5

Who is online

Users browsing this forum: No registered users and 2 guests