Git 2.13.0 broken on armv5

This forum is for topics dealing with problems with software specifically in the ARMv5 repo.

Git 2.13.0 broken on armv5

Postby madalu » Wed May 31, 2017 5:54 pm

I have a git server running on a pogoplug E02. With the upgrade to git 2.13.0-1, I am getting a sha1 mismatch error when running git commands. E.g., git log results in an error like this in every one of my repos:

error: sha1 mismatch 0aa4c063d23a04b2383de32ba8f6c313c71c9c43
fatal: bad object HEAD

If I downgrade to git-2.12.2-4, there are no errors, and there are no errors on other architectures with git 2.13.0-1.

[EDIT: By other architectures, I mean x86_64. I have not tried this on other arm architectures, so perhaps the problem is broader than armv5.]

Can others confirm?
madalu
 
Posts: 6
Joined: Tue Dec 15, 2015 3:55 am

Re: Git 2.13.0 broken on armv5

Postby madalu » Wed May 31, 2017 6:12 pm

OK. I realize that this properly belongs in the Packages subforum, so I will re-post there.
madalu
 
Posts: 6
Joined: Tue Dec 15, 2015 3:55 am


Return to ARMv5

Who is online

Users browsing this forum: No registered users and 3 guests