Static IP Not Working PogoPlug V2

This forum is for topics dealing with problems with software specifically in the ARMv5 repo.

Static IP Not Working PogoPlug V2

Postby calzon65 » Sun Jun 08, 2014 10:50 pm

I’ve been running two PogoPlug V2’s for a few years on Alarm, so I have a little experience. I wanted to do a full system restore today and read about the systemd issues, so I kept that in mind when I reinstalled. I am running the latest Kirkwood version, which I grabbed with the following command.

Code: Select all
wget http://archlinuxarm.org/os/ArchLinuxARM-kirkwood-latest.tar.gz

Once I installed the latest Alarm and connect to the system via SSH, I did run three pacman commands, but I ran them in a way to get around the systemd issues per Warheads SE’s suggestions in another post about the systemd problem.

Code: Select all
pacman -Syy
pacman -Su
pacman -S linux-kirkwood linux-kirkwood-headers

After the above three pacmans, I rebooted, and using my IP Scanner, found the IP address of the system then connected again via SSH to the dynamic IP address assigned to the system. Up to this point, I have made no changes to the system except for the three pacmans.

Next I wanted to configure a static IP address, as I have done dozens of times before. So I edited /etc/netctl/eth0 using the settings listed below.

Code: Select all
Description='Static Ethernet'
Interface=eth0
Connection=ethernet
IP=static
Address='192.168.179.40/24'
Gateway='192.168.179.1'
DNS=('192.168.179.1')

Finally I entered the command netctl enable eth0 and rebooted. This is the same static IP configuration I used before I decided to do a complete reinstall.

After I rebooted, I can’t SSH to the static IP address 192.168.179.40 nor can I see the system with my network IP scanner. There is no other system on my network with that IP address, but I also tried a different static IP address but no change. I am using netctl on my BeagleBone black with no problem, but my second PogoPlug is using an earlier “style” of static IP address control.

I also ran the commands netctl start eth0, netctl restart eth0, and netctl reload eth0. The only way I can connect to the system is to remove the USB thumb-drive, plug it into my other PogoPlug and modify the /etc/netctl/eth0 file to use DHCP.

Using netctl for a static IP address was working fine on this PogoPlug, but now it does not work and I am wondering if it has anything to do with the issues related to systemd. I am at a loss.
calzon65
 
Posts: 80
Joined: Wed May 25, 2011 9:06 pm

Re: Static IP Not Working PogoPlug V2

Postby pepedog » Mon Jun 09, 2014 12:24 am

You did not need to do netctl enable eth0
Or you could have done
systemctl disable netctl-ifplugd@eth0
pepedog
Developer
 
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: Static IP Not Working PogoPlug V2

Postby calzon65 » Mon Jun 09, 2014 4:43 am

Thank you for the feedback. After a fresh reinstall and NOT running the netctl enable eth0 command, it is working now.
calzon65
 
Posts: 80
Joined: Wed May 25, 2011 9:06 pm


Return to ARMv5

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest