new RPi4 archlinux lives!

This forum is for topics dealing with problems with software specifically in the ARMv6h repo.

new RPi4 archlinux lives!

Postby linuxauthor » Mon Mar 16, 2020 9:12 pm

hey folks... thought i'd pass on my experience on a new install of alarm on a 2GB rpi4 boxen w/a 32GB Samsung EvoPlus sdhc... please keep in mind that i knew absolutely nothing about archlinux before starting (although have been using GNU/Linux since 1994)

followed the directions at:

https://archlinuxarm.org/platforms/armv8/broadcom/raspberry-pi-4

- performed sdhc prep on an Ubuntu notebook (had to install bsdtar, although i think i could have also just used GNU tar)
- steps 3, and 4 required sudo
- step 7 required sudo
- made the card, put it into my rpi4
- hooked up to a TV and powered to see if it booted - yes! however, i wanted to configure wifi, so:
- logged in, changed default password (using the Logitech USB-fob wireless mouse/keyboard combo - handy!)
- logged in as root, changed default password
- tried using iw and a few others... no success... even created a wpa_supplicant.conf under /etc/wpa_supplicant
- finally, just ran wifi-menu -o to generate the required profile
- then ran:

netctl enable myprofile

to create the systemd service...

- rebooted
- success!

however, ran across a problem with su under /bin/su, which had foobar'd permissions resulting in a failure to get root status from the command line as the default alarm user... normally this wouldn't be a problem on a boxen w/head, keyboard, and mouse, but the rpi4 runs headless and needs to be administrated via ssh...

the fix which worked for me:

chown -R root:root /bin/su ; chmod 755 /bin/su ; chmod u+s /bin/su

now i had wifi up and had root privilege access after logging in as alarm via ssh...

finally, as root, i did a:

pacman -Syu

and now running:

Linux alarmpi 4.19.108-1-ARCH #1 SMP PREEMPT Tue Mar 10 02:06:04 UTC 2020 armv7l GNU/Linux

so that's where i am right now... hope this helps someone... i'll be adding some packages and will attempt an X and VNC install... then my rpi4 will be on its way as a wifi-controlled SDR streaming radio transceiver... i already have a working receiver-only streaming setup using gqrx on the Ubuntu boxen, which allows me to roam throughout the house and yard, listening to amateur radio bands, aircraft, FM country stations, NOAA WX, and AM talk radio using BT headphones - lots of fun!

willie
on the Gulf of Mexico
linuxauthor
 
Posts: 1
Joined: Mon Mar 16, 2020 8:40 pm

Re: new RPi4 archlinux lives!

Postby RuneArch » Sun Mar 29, 2020 10:47 am

I've setup a few Raspberry Pi's with Arch Linux for ARM over the years and I don't think I've had a problem getting from alarm to root, but an interesting post.

The entire installation is written as a root user would use, so you're correct, sudo would be needed on those steps. However, it's sometimes "better" (subjective) to perform the entire installation as root - you then ensure that partitions are created and owned by root up front... so perhaps that lead on to your issues with su...??

Just picking up on your wifi issue - personally - I was prefer to encrypt my wifi password in the wpa_supplicant.conf file - so if yours isn't then have a look at https://wiki.archlinux.org/index.php/Wpa_supplicant#Connecting_with_wpa_passphrase - this will also output the plaintext password (so you can verify you typed it correctly), but I just delete that line.

From memory (rose-tinted ;)) - I think I just copied in my wpa_supplicant.conf from another install, and it just worked on first power up

But, at least you're up & running...
RuneArch
 
Posts: 2
Joined: Fri Mar 27, 2020 10:23 am


Return to ARMv6h

Who is online

Users browsing this forum: No registered users and 1 guest