All packages downloaded with pacman are corrupt (Rpi3)

This forum is for topics dealing with problems with software specifically in the ARMv6h repo.

All packages downloaded with pacman are corrupt (Rpi3)

Postby LucaRicardo » Tue May 12, 2020 10:43 am

I just installed arch linux on my raspberry pi and after booting first time I connected it with ethernet to my router and runned the command:
Code: Select all
pacman-key init

which worked just fine then i typed:
Code: Select all
pacman -Syu

and everything worked just fine until the end where it just said
Code: Select all
error: iana-etc: signature from "Arch Linux ARM Build System <builder@archlinuxarm.org>" is unknown trust
: : File /var/cache/pacman/pkg/iana-etc-20200428-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

for all packages and then after I had deleted them all it just ended the process by saying no packages were upgraded. I tried reinstalling Arch Linux ARM and I even re-downloaded Arch Linux ARM, but I just received the same error. <

Does anyone know how I can fix it?
LucaRicardo
 
Posts: 1
Joined: Tue May 12, 2020 10:15 am

Re: All packages downloaded with pacman are corrupt (Rpi3)

Postby normaal » Thu May 28, 2020 11:45 am

Similar case in my side just few days ago. Culprit was normal dieing sd card, what was actually transparently in ReadOnly mode.

Try this: take sd card out to other bigger linux computer, try fsck -fy /dev/sdb1 and fsck -fy /dev/sdb2 or what ever these sd card partiotions are in that machine. If fsck has something to fix, let it do it. Then do it again.... and if it want to fix something again - then you may have dieing (R0) card syndrom. Make disk image (dd if=/dev/sdb of=/full.img), find new sd card and burn that image to new card ( dd if=/full.img of=/dev/sdb ), now try to fsck on that new card- if you can fix it with first run and second run has no errors- then you can go back to your RPi3 and run pacman Syu there.

I got my rp back to business without reinstall in this way. Good luck.
normaal
 
Posts: 11
Joined: Mon Feb 09, 2015 9:52 pm

Re: All packages downloaded with pacman are corrupt (Rpi3)

Postby moonman » Thu May 28, 2020 10:51 pm

You didn't finish initializing the keyring. https://archlinuxarm.org/platforms/armv6/raspberry-pi installtion tab
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3264
Joined: Sat Jan 15, 2011 3:36 am


Return to ARMv6h

Who is online

Users browsing this forum: No registered users and 1 guest