Can't compile software of mine

This forum is for topics dealing with problems with software specifically in the ARMv6h repo.

Can't compile software of mine

Postby obiwankennedy » Sun Feb 19, 2017 10:16 pm

Hi all,

I'm trying to compile a software of mine on ArchLinuxArm on RP 3. I run into this error:
"internal compiler error: Segmentation fault". G++ does not work correctly.

Any clue ?

My application is written in C++ with Qt. I already succeed to compile it few times, few weeks ago. But now, I always got the error.

This is the output of the compilation:

Code: Select all
make
g++ -c -pipe -O2 -march=armv8-a -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_DBUS_LIB -DQT_CORE_LIB -I../../TwitterBot -I. -I../libtwitcurl -I../libtwitcurl/libtwitcurl/include -I../diceparser/result -I../diceparser/node -I../diceparser -isystem /usr/include/qt -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtDBus -isystem /usr/include/qt/QtCore -I. -I/usr/lib/qt/mkspecs/linux-g++ -o main.o ../main.cpp
<built-in>: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://github.com/archlinuxarm/PKGBUILDs/issues> for instructions.
make: *** [Makefile:687: main.o] Error 1
obiwankennedy
 
Posts: 3
Joined: Sun Feb 19, 2017 10:10 pm

Re: Can't compile software of mine

Postby WarheadsSE » Mon Feb 20, 2017 1:48 pm

Is your userland 32-bit armv7/armv7-a, or is it 64-bit aarch64/armv8-a?
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6727
Joined: Mon Oct 18, 2010 2:12 pm

Re: Can't compile software of mine

Postby obiwankennedy » Mon Feb 20, 2017 5:56 pm

My kernel is Linux steel 4.9.11-1-ARCH #1 SMP Sat Feb 18 17:46:25 MST 2017 aarch64 GNU/Linux, so 64bits but my userland, I don't know. How could I know that ?

all software that I succeed to compile are in 64bits:
ELF 64-bit LSB executable, ARM aarch64, version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, BuildID[sha1]=bdfe2eefced62ebd6707b64d3b6d58659770bba6, not stripped, with debug_info


and gcc:
file /usr/bin/gcc
/usr/bin/gcc: ELF 64-bit LSB executable, ARM aarch64, version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, BuildID[sha1]=1cff269eb8b8005d953935489bdafc345d108b65, stripped, with debug_info

What's else can I check ?
obiwankennedy
 
Posts: 3
Joined: Sun Feb 19, 2017 10:10 pm

Re: Can't compile software of mine

Postby WarheadsSE » Mon Feb 20, 2017 9:51 pm

That's pretty much all I needed for confirmation that your environment all matches
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6727
Joined: Mon Oct 18, 2010 2:12 pm

Re: Can't compile software of mine

Postby obiwankennedy » Wed Feb 22, 2017 7:09 am

Is there a solution ? Do I have to reinstall ? I tried yesterday to reinstall my package. Does not change a thing.
obiwankennedy
 
Posts: 3
Joined: Sun Feb 19, 2017 10:10 pm

Re: Can't compile software of mine

Postby WarheadsSE » Wed Feb 22, 2017 1:27 pm

We'd need to replicate the problem. We've not seen this in building our packages, obviously.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6727
Joined: Mon Oct 18, 2010 2:12 pm


Return to ARMv6h

Who is online

Users browsing this forum: No registered users and 3 guests