Mono illegal instructions

This forum is for topics dealing with problems with software specifically in the ARMv6h repo.

Mono illegal instructions

Postby pimOOsse » Wed May 31, 2017 6:48 pm

Hi,

I'm running an ArchLinux on Raspberry PI 2 model B since few months.

All was working fine but after a system update some time ago (don't remember when...) I got with illegal exceptions when running my existing .NET programs...

Without AOT, it was able to launch them, but is was a workaround IMO.

Recently I had another problem with TLS exceptions although it was working well before... so I wanted to use mozroots command but it also trigger illegal instructions when running it !

Updating Mono from 4.x to 5.0 didn't solved anything.

Connected as root, I ran the following command after some searches (missing certificates) :

mono --aot /usr/lib/mono/4.5/mscorlib.dll

But I have the following error :

Mono Ahead of Time compiler - compiling assembly /usr/lib/mono/4.5/mscorlib.dll
Code: 5304072(86%) Info: 126802(2%) Ex Info: 182683(2%) Unwind Info: 185033(3%) Class Info: 102272(1%) PLT: 7149(0%) GOT Info: 132042(2%) Offsets: 109454(1%) GOT: 64016
Compiled: 25177/25179 (99%), No GOT slots: 16057 (63%), Direct calls: 39344 (81%)
Executing the native assembler: "as" -o /tmp/mono_aot_cJ1bZa.o /tmp/mono_aot_cJ1bZa
AOT of image /usr/lib/mono/4.5/mscorlib.dll failed.

Don't know why, but my Mono experience with Archlinux and Raspberry (ARM processor ?) is more and more bad.

Any idea to solve this behaviour ?

Best regards,

Florian
pimOOsse
 
Posts: 1
Joined: Wed May 31, 2017 6:15 pm

Return to ARMv6h

Who is online

Users browsing this forum: No registered users and 1 guest