Kernel panic when running mpd (& truecrypt?)

This forum is for topics dealing with problems with software specifically in the ARMv6h repo.

Kernel panic when running mpd (& truecrypt?)

Postby mox » Mon May 05, 2014 11:30 am

Hi everyone,

I use my raspberry pi as a headless music player using mpd. For the last few months, after some time the ssh connection would be lost without any way to control the pi so I had to just pull the plug and reboot ist. Now I got a monitor and a keyboard and hooked them to it, re-installed the newest Archlinux Iso and then moved the root folder to the harddrive as described here (http://c-mobberley.com/wordpress/2013/0 ... to-usb-hdd). Then I set up truecrypt and mpd. So far, the pi worked flawlessly. But when I start truecrypt and mpd, the pi crashes. Most times it crashes immediately, but sometimes it will run for some time before the crash.
This is the output I get on the screen, when it crashes (My ssh connection just dies):

steps:
truecrypt (to set up the music folder)
mount music folder to /music
mpd

Code: Select all
[...] Bad mode in undefined instruction handler detected
[...] Internal error: Oops - bad mode: 0 [#1] PREEMPT ARM

Entering kbd (current=0xc34a7080, pid 2061) Oops: (null)
[-]dCPU: 0 PID: 2601 Cmm: mpd Not tainted 3.10.38-1-ARCH #1
[-]dtask: c34a7080 ti: c5ac4000 task.ti: c5ac4000
PC is at fiq_sof_handle+0xa0/0x10c
LP is at 0xb5312ac4
sp : [<c042d858>]   lr: [<b5312ac4>] psr: 800001d1
r10: ... r9: ... r0: ...
Flags: Nzcv IRQs off FIQs off Mode FIQ_32 ISA ARM Segment user
Control: 00c5387d Table: 058b4008 DAC: 00000015
[c]dCPU: 0 PID: 2061 Comm: mpd Not tainted 3.10.38-1-ARCH #1
[<...>] (unwind_backtrace+0x0/0xec) from [<...>] (show_stack+0x10/0x14)
[<...>] (show_stack+0x10/0x14) from [<...>] (dkb_dumpregs+0x28/0x50)
[<...>] (kdb_main_loop+0x370/0x6bc) from [<...>] (kdb_stub+0x164/0x380)
more> _


Does anyone else experience this behaviour? Am I correct in assuming this is a missing interrupt vector? And should I file a bug report for this, or is there a known solution for this that I just did not find?

Sincerely,
mox
mox
 
Posts: 1
Joined: Mon May 05, 2014 11:10 am

Return to ARMv6h

Who is online

Users browsing this forum: zebul666 and 1 guest