Allo Piano kernel module not loading

Plugging in devices such as LAN adapters, Wi-Fi cards, printers, etc. to Arch Linux ARM.

Allo Piano kernel module not loading

Postby gattumarrudu » Wed Oct 14, 2020 2:41 am

Hello,
When I first installed ArchLinuxARM (ARMv7) on my Rpi3 I got my Allo Piano DAC Plus board to work without a problem.

After some updates (severalmonths ago) it stopped working and I get these messages in the journal:

Code: Select all
Sep 14 07:08:34 alarmpi kernel: snd-allo-piano-dac-plus soc:sound: ASoC: Neither/both codec name/of_node are set for PianoDACPlus
Sep 14 07:08:34 alarmpi kernel: snd-allo-piano-dac-plus soc:sound: ASoC: failed to init link PianoDACPlus: -22
Sep 14 07:08:34 alarmpi kernel: snd-allo-piano-dac-plus soc:sound: snd_soc_register_card() failed: -22
Sep 14 07:08:34 alarmpi kernel: snd-allo-piano-dac-plus: probe of soc:sound failed with error -22


My /boot/config.txt:

Code: Select all
# See /boot/overlays/README for all available options

# Memory
gpu_mem=16

# Sound
dtparam=audio=on
dtparam=i2s=on
dtoverlay=allo-piano-dac-plus-pcm512x-audio,glb_mclk

# Misc
# setting the max usb current to 1200mA
max_usb_current=1

# Boot
boot_delay=2
initramfs initramfs-linux.img followkernel


ls -la /boot/overlays/allo-*:

Code: Select all
-rwxr-xr-x 1 root root 1469 Oct  7 08:33 /boot/overlays/allo-boss-dac-pcm512x-audio.dtbo
-rwxr-xr-x 1 root root 1208 Oct  7 08:33 /boot/overlays/allo-digione.dtbo
-rwxr-xr-x 1 root root 1659 Oct  7 08:33 /boot/overlays/allo-katana-dac-audio.dtbo
-rwxr-xr-x 1 root root 1011 Oct  7 08:33 /boot/overlays/allo-piano-dac-pcm512x-audio.dtbo
-rwxr-xr-x 1 root root 1585 Oct  7 08:33 /boot/overlays/allo-piano-dac-plus-pcm512x-audio.dtbo


aplay -l:

Code: Select all
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3


Can someone please help me figure out what's wrong?

Thank you.
gm
gattumarrudu
 
Posts: 5
Joined: Mon Oct 29, 2018 5:59 pm

Re: Allo Piano kernel module not loading

Postby gattumarrudu » Sun Oct 18, 2020 5:44 am

Anyone able to help? Can I patch the module or is it closed source? If it is, can I downgrade the kernel? Any hint would be helpful. I use this RPI as a DACfor my HiFi and without this module it's useless. I don't really want to replace Arch which I have been working on for many years on i386 machines. Thanks.
gattumarrudu
 
Posts: 5
Joined: Mon Oct 29, 2018 5:59 pm


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest