sudo raspi-config and ensure that "camera" has been enabled

Plugging in devices such as LAN adapters, Wi-Fi cards, printers, etc. to Arch Linux ARM.

sudo raspi-config and ensure that "camera" has been enabled

Postby dimytch » Sat Jun 16, 2018 7:08 am

I can't enable camera under Arch on Raspberri PI 3 B.
Spent about 4 hours for googling. Please, anybody, give me the hint.
ArmV7, camera is Waveshare F, installed ArchLinuxARM-rpi-2-latest.tar.gz

Code: Select all
[root@pi ~]# /opt/vc/bin/raspivid -l -o tcp://0.0.0.0:3333
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not enabled in this build. Try running "sudo raspi-config" and ensure that "camera" has been enabled

[root@pi ~]# cat /boot/config.txt
# See /boot/overlays/README for all available options

# gpu_mem=64
initramfs initramfs-linux.img followkernel gpu_mem=128 start_file=start_x.elf fixup_file=fixup_x.dat cma_lwm= cma_hwm= cma_offline_start= dtparam=audio=on
dimytch
 
Posts: 2
Joined: Fri Jun 15, 2018 9:27 pm

Re: sudo raspi-config and ensure that "camera" has been enab

Postby dimytch » Sat Jun 16, 2018 8:21 am

Why the resolution is always found after I ask for help?
There is an raspi-config in AUR.
dimytch
 
Posts: 2
Joined: Fri Jun 15, 2018 9:27 pm


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

cron