Can't get my RTL8192CU based card to work

Plugging in devices such as LAN adapters, Wi-Fi cards, printers, etc. to Arch Linux ARM.

Can't get my RTL8192CU based card to work

Postby cm03 » Sun May 24, 2015 10:14 pm

Hey Guys,

I've been trying to get my Wifi-Adapter working, and to be honest, so far I have failed miserably :)

Code: Select all
[root@demo ~]# lsusb | grep 005
Bus 001 Device 005: ID 0b05:17ab ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU]

I tried installing different drivers from the AUR, searched for patched ones, built dkms modules, blacklisted modules and so on, but couldn't get it work at all. My only remaining options are to ask you guys or to simply install another distribution, which I would like to avoid if possible.

I ran some commands that could be useful:

Code: Select all
[root@demo ~]# ip addr
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 10:[...]:1d brd ff:ff:ff:ff:ff:ff

Code: Select all
[root@demo ~]# lsmod
Module                  Size  Used by
nfnetlink_queue        11347  0
nfnetlink_log           9007  0
nfnetlink               6654  2 nfnetlink_log,nfnetlink_queue
bluetooth             295809  0
cfg80211              446667  0
8192cu                516676  0
uio_pdrv_genirq         3238  0
uio                     8753  1 uio_pdrv_genirq
sch_fq_codel            7611  2
snd_bcm2835            19280  0
snd_pcm                84574  1 snd_bcm2835
snd_timer              20697  1 snd_pcm
snd                    61017  3 snd_bcm2835,snd_timer,snd_pcm
bcm2708_rng             1044  0
rng_core                5666  1 bcm2708_rng
ipv6                  328297  18

Code: Select all
[root@demo ~]# iw dev
[root@demo ~]#

Code: Select all
[root@demo ~]# iwconfig wlan0
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Code: Select all
[root@demo ~]# airmon-ng start wlan0
No interfering processes found
PHY     Interface       Driver          Chipset

null    wlan0           rtl8192cu       ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU]

Code: Select all
[root@demo ~]# iw dev wlan0 scan
command failed: No such device (-19)

Right now I pretty much reversed all the changes I've made to the system and am now at a "clean state".
What would you recommend that I try now?

Any help would be greatly appreciated :)

Posts: 2
Joined: Sun May 24, 2015 10:01 pm

Re: Can't get my RTL8192CU based card to work

Postby tempest » Mon May 25, 2015 12:00 am

I followed the advice by moesguaard from
I suggest adding this to the package for black listing.

blacklist rtl8192cu
blacklist rtl8192c_common
blacklist rtl_usb
blacklist rtlwifi
blacklist mac80211
blacklist cfg80211
blacklist rfkill

because i went from a maximum 10Mbps to my top speed of 50Mbps just by adding those extra lines.

I blacklisted everything he suggested, but found that a a few on the list still loaded due to dependencies (the integrated broadcom wifi in my case).
Try blacklisting cfg80211. If it still loads, do a:
Code: Select all
modprobe --show-depends cfg80211

and blacklist whatever is invoking it. I am pretty sure that my wifi has gotten *much* more stable since I have done so, but there still the off chance that is is the placebo effect.
Posts: 3
Joined: Sun May 24, 2015 11:41 pm

Re: Can't get my RTL8192CU based card to work

Postby cm03 » Tue May 26, 2015 3:09 pm

I got it to work! :)

First of all I made sure to remove all traces of my failure by deinstalling and removing all packages/files that I previously tampered with.
After that I installed these two Packages:

Code: Select all
[root@demo ~]# pacman -Q | grep 8192
dkms-8192cu v4.0.2_9000.20130911-2
hostapd-8192cu 0.8_rtw_r7475.20130812_beta-3

I then installed this:
I am now able to create a software-ap that others can connect to. The Speed I get isn't spectacular but it isn't going to be used by a lot of devices at once so I'm okay with that.
Im going to blacklist the modules you mentioned anyway :)

Thanks a lot!
Posts: 2
Joined: Sun May 24, 2015 10:01 pm

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest