Cubox-i DBUS start fails

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

Cubox-i DBUS start fails

Postby chylee » Tue Feb 23, 2021 3:27 pm

I have a cubox-i4p just installed arch but for some reason can't get dbus service to run.
Code: Select all
systemctl status dbus.socket
● dbus.socket - D-Bus System Message Bus Socket
     Loaded: loaded (/usr/lib/systemd/system/dbus.socket; static)
     Active: failed (Result: service-start-limit-hit) since Tue 2021-02-23 15:19:01 UTC; 1min 1s ago
   Triggers: ● dbus.service
     Listen: /run/dbus/system_bus_socket (Stream)

Feb 23 15:19:00 alarm systemd[1]: Listening on D-Bus System Message Bus Socket.
Feb 23 15:19:01 alarm systemd[1]: dbus.socket: Failed with result 'service-start-limit-hit'.

systemctl status dbus.service
● dbus.service - D-Bus System Message Bus
     Loaded: loaded (/usr/lib/systemd/system/dbus.service; static)
     Active: failed (Result: exit-code) since Tue 2021-02-23 15:19:01 UTC; 1min 7s ago
TriggeredBy: ● dbus.socket
       Docs: man:dbus-daemon(1)
    Process: 23087 ExecStart=/usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslo>
   Main PID: 23087 (code=exited, status=1/FAILURE)

Feb 23 15:19:00 alarm systemd[1]: Started D-Bus System Message Bus.
Feb 23 15:19:01 alarm dbus-daemon[23087]: Failed to start message bus: Failed to drop capabilities: Invalid argument
Feb 23 15:19:01 alarm systemd[1]: dbus.service: Main process exited, code=exited, status=1/FAILURE
Feb 23 15:19:01 alarm systemd[1]: dbus.service: Failed with result 'exit-code'.
Feb 23 15:19:01 alarm systemd[1]: dbus.service: Start request repeated too quickly.
Feb 23 15:19:01 alarm systemd[1]: dbus.service: Failed with result 'exit-code'.
Feb 23 15:19:01 alarm systemd[1]: Failed to start D-Bus System Message Bus.

Last edited by chylee on Tue Apr 20, 2021 2:33 pm, edited 1 time in total.
chylee
 
Posts: 2
Joined: Mon Jan 04, 2021 5:53 pm

Re: cubox-i pro no dbus service

Postby elQuero » Fri Mar 12, 2021 3:35 pm

Hi, I'm getting the same error. Did you find any way to resolve it?

I think also that the thread title should be change to something more meaningfull, like "Cubox-i DBUS start fails"
elQuero
 
Posts: 3
Joined: Sun Aug 16, 2015 3:55 pm

Re: cubox-i pro no dbus service

Postby chylee » Tue Apr 20, 2021 2:33 pm

No I have not. I've moved to an orange pi zero 2 and running ubuntu. Cubox is not well supported the only distro that run well was arch well now I can't use it. I like arch but at some point it fails me.
chylee
 
Posts: 2
Joined: Mon Jan 04, 2021 5:53 pm

Re: Cubox-i DBUS start fails

Postby hirnsushi » Thu May 13, 2021 2:05 pm

Upgrading the system to the linux-armv7-cubox kernel fixed this problem for me.
Might be to late for you, but maybe someone else finds this useful.
hirnsushi
 
Posts: 1
Joined: Thu May 13, 2021 1:56 pm


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 7 guests