NanoPi M1 + Xorg

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

NanoPi M1 + Xorg

Postby bamboo » Wed Apr 24, 2024 9:35 pm


I am aware that I am totally on the unsupported side and that the device is old, so I kindly ask for help.

I tried to follow this guide [url][/url] and I got working Arch instalation ... until I tried to run GUI.

Can somebody point me a direction how to debug Xorg log:

# startx

(EE) Backtrace:
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

That's not a mistake - the log looks literally like this. No X.conf present. It should use Lima driver (checked lsmod and it is loaded). Well but all I know is that an exception occured. No message, no backtrace. It producers the same log when I try to start LightDM.

# dmesg | grep lima
[ 5.146836] lima 1c40000.gpu: gp - mali400 version major 1 minor 1
[ 5.157625] lima 1c40000.gpu: pp0 - mali400 version major 1 minor 1
[ 5.186365] lima 1c40000.gpu: pp1 - mali400 version major 1 minor 1
[ 5.192864] lima 1c40000.gpu: l2 cache 64K, 4-way, 64byte cache line, 64bit external bus
[ 5.227879] lima 1c40000.gpu: bus rate = 200000000
[ 5.242829] lima 1c40000.gpu: mod rate = 297000000
[ 5.253061] lima 1c40000.gpu: error -ENODEV: _opp_set_regulators: no regulator (mali) found
[ 5.272350] [drm] Initialized lima 1.1.0 20191231 for 1c40000.gpu on minor 1
Posts: 3
Joined: Mon Jun 21, 2021 9:19 am

Re: NanoPi M1 + Xorg

Postby robg » Thu Apr 25, 2024 8:04 am

To isolate the driver as the source of your problem, first try launching X without the Mali GPU. That is, uninstall the driver and see if X works with xf86-video-fbdev[1] or KMS[2].

[1]make_clickable_callback(MAGIC_URL_FULL, ' ', '', '', ' class="postlink"')
[2]make_clickable_callback(MAGIC_URL_FULL, ' ', '', '', ' class="postlink"')
Posts: 187
Joined: Tue Jan 05, 2021 8:22 am

Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 4 guests