[SOLVED] Python 2.7 is broken

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

Re: [!] Python 2.7 is broken

Postby CaptainRage » Fri May 19, 2017 12:45 pm

Does this concern armv6h as well or is it safe to upgrade?
CaptainRage
 
Posts: 9
Joined: Fri Mar 15, 2013 3:56 pm

Re: [!] Python 2.7 is broken

Postby WarheadsSE » Fri May 19, 2017 2:30 pm

It is all dependent on the age of your kernel.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6730
Joined: Mon Oct 18, 2010 2:12 pm

Re: [!] Python 2.7 is broken

Postby CaptainRage » Fri May 19, 2017 5:10 pm

Oh. It concerns a Raspberry Pi B+.

Code: Select all
$ uname -a
Linux Abcdefg 4.9.28-2-ARCH #1 SMP Wed May 17 01:05:34 UTC 2017 armv6l GNU/Linux


I haven't found any info regarding this issue on the aforementioned kernel and architecture. Actually, python2 2.7.13-2 is already installed. Then I assume I can go ahead and upgrade an AUR package that depends on python2. If there is any nifty command to see whether my installation is affacted by this bug, don't hesitate to share it. Thank you very much for the information already provided.

EDIT:
The upgrades proceeded without problems. Thank you for the clarification, WarheadsSE.
Last edited by CaptainRage on Fri May 19, 2017 9:37 pm, edited 1 time in total.
CaptainRage
 
Posts: 9
Joined: Fri Mar 15, 2013 3:56 pm

Re: [!] Python 2.7 is broken

Postby WarheadsSE » Fri May 19, 2017 6:52 pm

Your kernel is new enough that this should not be an issue.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6730
Joined: Mon Oct 18, 2010 2:12 pm

Re: [!] Python 2.7 is broken

Postby RMJ » Mon May 29, 2017 11:36 pm

$ uname -a
Linux alarm 3.8.11-4-ARCH #1 SMP Sat Oct 22 11:59:55 MDT 2016 armv7l GNU/Linux

What about mine? Is there any newer kernel for this machine?
RMJ
 
Posts: 29
Joined: Fri May 05, 2017 9:32 pm

Re: [!] Python 2.7 is broken

Postby gangely » Mon Jun 05, 2017 1:57 pm

Maybe it is not related, but while tracing MoinMoin errors, I found similar Python2.7 errors (ERROR:root:code for hash sha512 was not found ..) related to openssl package.
You could try:
- downgrading to the former openssl 1.1 package (openssl 1.1.0.e-1)
- installing openssl-1.0: you will have both libraries
Be careful if you simply downgrade to openssl 1.0: a lot of things seems to depend now on openssl 1.1.
gangely
 
Posts: 2
Joined: Thu Jul 09, 2015 9:39 am

Re: [!] Python 2.7 is broken

Postby frol » Mon Jul 03, 2017 8:27 pm

Downgrade to 2.7.13-1 made things only worse, so I had to dig into the issue since Kodi still doesn't support Python 3 (which works just fine on my system). The workaround turned out to be a manual replacement of `/usr/lib/libpython2.7.so.1.0` from the python2-2.7.13-1 package. This worked for me, so I figured I would share it.

P.S. I have downloaded the 2.7.13-1 package from one of the mirrors: https://fraggod.net/static/mirror/packa ... pkg.tar.xz
frol
 
Posts: 3
Joined: Mon Oct 24, 2016 10:40 am

Re: [!] Python 2.7 is broken

Postby RMJ » Wed Jul 05, 2017 2:24 am

So here's the status:

We reported the problem with the package: python2-2.7.13-2

I just tested the python2-2.6.13-3, and the problem with /usr/lib/python2.7/random.py is still there.

As pointed in a early topic:
you can change both "except NotImplementedError" instances by "except (NotImplementedError, OSError)" inside random.py, it worked for me.
RMJ
 
Posts: 29
Joined: Fri May 05, 2017 9:32 pm

Re: [!] Python 2.7 is broken

Postby steals » Wed Jul 19, 2017 5:36 pm

@ frol
The workaround turned out to be a manual replacement of `/usr/lib/libpython2.7.so.1.0` from the python2-2.7.13-1 package. This worked for me, so I figured I would share it.

Did you mean to fully upgrade to the latest version of python and downgrade only /usr/lib/libpython2.7.so.1.0 ?
steals
 
Posts: 6
Joined: Tue Sep 06, 2016 12:55 pm

Re: [!] Python 2.7 is broken

Postby steals » Sun Aug 06, 2017 10:44 am

Just updated to 2.7.13-4 and the initial error still occurs.
steals
 
Posts: 6
Joined: Tue Sep 06, 2016 12:55 pm

PreviousNext

Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 1 guest