Rpi 3 python librarie problem

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

Rpi 3 python librarie problem

Postby RUWOCoder » Tue May 16, 2017 6:09 am

So i,m runnning a rpi3 with armv7. I installed python and the rpi.gpio librarie, but if i run a program with it, i get runtime error: this module can only be run on a raspberry pi!
Any help would be aprieceated
RUWOCoder
 
Posts: 1
Joined: Tue May 16, 2017 5:57 am

Re: Rpi 3 python librarie problem

Postby bulletmark » Wed May 17, 2017 1:31 am

There is no package called rpi.gpio. What package did you actually install and from where?

I installed the AUR package python-raspberry-gpio (which provides RPi.GPIO) on my RPi3 and it works fine.
bulletmark
 
Posts: 38
Joined: Tue Oct 13, 2015 10:17 pm


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 3 guests