[quasi-SOLVED]: Cubietruck doesn't boot/systemd stuck

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

[quasi-SOLVED]: Cubietruck doesn't boot/systemd stuck

Postby figue » Tue Dec 12, 2017 7:16 pm

Hello, yesterday my Cubietruck stop booting anymore. It's odd because I see kernel load in HDMI screen, then the welcome message to Arch Linux, set the hostname, and then stop. I tried to boot with another disk successfully, then make a chroot and reinstalled systemd, kernel, etc. No luck. Even I reinstalled all explicit installed packages. I also downgrade the latest packages upgrades... I tried to change mkinitcpio hooks, but nothing. So should be something else.

Anyone know what I can do or test? Can I see if something in systemd is wrong from chroot?

Thank you

PS: I also tried to install uboot-cubietruck and update my boot.scr without success


EDIT: After more tests, I finally decide to compile a kernel myself. I did with danand's config for a long time and always worked, but a couple of months ago I switch to Arch's kernel, as it worked fine too. But, now, a stock kernel with danand's config give me a kernel panic at boot :shock:
So, what I did? I make a new boot.scr with debug flags enabled (setenv bootargs console=tty1 root=/dev/sda1 rw rootwait systemd.log_level=debug systemd.log_target=console) and I saw a lot of messages like "Set up TFD_TIMER_CANCEL_ON_SET timerfd", "Time has changed".
So, my problem seems to be an internal component (the real-time internal clock) which seems dead/fails. My workaround for almost a year was disable CONFIG_RTC_HCTOSYS in kernel... So, when I did this with the Arch's kernel it worked. Systemd is loading again and everything seems to work. As I never cross-compiled for Arch, I have to adapt the PKGBUILD a little to build in a desktop computer running x86_64... Seems it's a success for now.
figue
 
Posts: 1
Joined: Sun Aug 12, 2012 1:33 pm

Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 5 guests