[Solved] Cannot connect to some secure sites

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

[Solved] Cannot connect to some secure sites

Postby thorsten » Sat Aug 25, 2018 8:51 pm

Hello everybody,

I'm running archlinuxarm on my Cubietruck for about 2 years now and everything was fine until a few days ago.
Unfortunately I cannot connect to some secure websites any more and I don't know where to start searching for a solution.

For example if I try to test the ssl connection to framagit.org by using
Code: Select all
openssl s_client -connect framagit.org:443 -state -nbio 2>&1 | grep "^SSL"

I only get to
Code: Select all
SSL_connect:before SSL initialization
SSL_connect:SSLv3/TLS write client hello
SSL_connect:error in SSLv3/TLS write client hello


Other sides are working fine, like github:
Code: Select all
SSL_connect:before SSL initialization
SSL_connect:SSLv3/TLS write client hello
SSL_connect:error in SSLv3/TLS write client hello
SSL_connect:SSLv3/TLS write client hello
SSL_connect:SSLv3/TLS read server hello
SSL_connect:SSLv3/TLS read server certificate
SSL_connect:SSLv3/TLS read server key exchange
SSL_connect:SSLv3/TLS read server done
SSL_connect:SSLv3/TLS write client key exchange
SSL_connect:SSLv3/TLS write change cipher spec
SSL_connect:SSLv3/TLS write finished
SSL_connect:error in SSLv3/TLS write finished
SSL_connect:SSLv3/TLS write finished
SSL_connect:SSLv3/TLS read change cipher spec
SSL_connect:SSLv3/TLS read finished
SSL handshake has read 3586 bytes and written 302 bytes


Has anybody a hint for me how I can find the reason for this problem?

Thanks in advance,
Thorsten
Last edited by thorsten on Mon Sep 03, 2018 7:41 pm, edited 1 time in total.
thorsten
 
Posts: 4
Joined: Sat Aug 25, 2018 8:42 pm

Re: Cannot connect to some secure sites

Postby thorsten » Thu Aug 30, 2018 9:17 pm

After some experiments I downgraded my openssl from 1.1.0 to 1.0.1 and somehow it worked.
Is there an issue with openssl 1.1.0?

Btw: I learned that one should be very careful when downgrading openssl. I nearly destroyed my archARM-Installation but finally I managed to get openssl 1.1.0 work again. :roll:
thorsten
 
Posts: 4
Joined: Sat Aug 25, 2018 8:42 pm

Re: Cannot connect to some secure sites

Postby thorsten » Fri Aug 31, 2018 9:15 pm

So it is possible to install the openssl-1.0 package next to the openssl 1.1. and version 1.0 works fine for me.
Can I find the information when openssl 1.1 became default?
thorsten
 
Posts: 4
Joined: Sat Aug 25, 2018 8:42 pm

Re: Cannot connect to some secure sites

Postby thorsten » Sun Sep 02, 2018 6:11 pm

Somehow IPV6 was activated on my router although I can't remember that I activated it.
After deactivating everything works fine again.

So if somebody has problems with openssl-connections "-4" for Use IPV4 or "-6" for IPV6 may be worth a try :)

Thread can be closed as solved (or must do this?).
thorsten
 
Posts: 4
Joined: Sat Aug 25, 2018 8:42 pm

Re: Cannot connect to some secure sites

Postby TheSaint » Mon Sep 03, 2018 2:04 am

Change the title on the first post by edit it.
TheSaint
 
Posts: 242
Joined: Mon Jul 23, 2018 7:57 am


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 2 guests