[RPI 3B+] Bluetooth not working after upgrade

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

[RPI 3B+] Bluetooth not working after upgrade

Postby archARMRapberry » Wed Aug 26, 2020 4:25 pm

Hello,

i have a RaspberryPi 3B+ with Arch ARM running since a couple of years. I successfully installed / enabled bluetooth with the following steps, but since updating packages last weekend I'm not able to bring bluetooth up again:

Code: Select all
sudo bluetoothctl
Agent registered
[bluetooth]# power on
No default controller available
[bluetooth]# scan on
No default controller available
[bluetooth]# exit


Also bluetooth.service does not start autmatically after a reboot (inactive(dead)). It did previously and if restart the service it starts just fine:

Code: Select all
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2020-08-26 14:28:29 CEST; 8s ago
       Docs: man:bluetoothd(8)
   Main PID: 1501 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 2154)
     CGroup: /system.slice/bluetooth.service
             └─1501 /usr/lib/bluetooth/bluetoothd

Aug 26 14:28:29 raspberry-server systemd[1]: Starting Bluetooth service...
Aug 26 14:28:29 raspberry-server bluetoothd[1501]: Bluetooth daemon 5.54
Aug 26 14:28:29 raspberry-server systemd[1]: Started Bluetooth service.
Aug 26 14:28:29 raspberry-server bluetoothd[1501]: Starting SDP server
Aug 26 14:28:30 raspberry-server bluetoothd[1501]: Bluetooth management interface 1.14 initialized


I did update the following packages but I'm unsure which one could be the issue. I guess anything from firmware to bluetooth.service ?!

Code: Select all
* alsa-lib 1.2.3.1-1 -> 1.2.3.2-1
   * bash 5.0.017-1 -> 5.0.018-1
   * bridge-utils 1.6-4 -> 1.7-1
   * ca-certificates 20181109-3 -> 20181109-4
   * ca-certificates-mozilla 3.54-1 -> 3.55-2
   * ca-certificates-utils 20181109-3 -> 20181109-4
   * cadaver 0.23.3-11 -> 0.23.3-12
   * containerd 1.3.4-2 -> 1.4.0-2
   * curl 7.71.0-1 -> 7.71.1-1
   * dbus 1.12.18-1 -> 1.12.20-1
   * dhcpcd 9.1.2-2 -> 9.1.4-2
   * dnscrypt-proxy 2.0.39-1 -> 2.0.44-1 [ignored]
   * docker 1:19.03.11-1 -> 1:19.03.12-2
   * docker-compose 1.26.0-1 -> 1.26.2-1
   * exfat-utils 1.3.0-1 -> 1.3.0-2
   * fuse-common 3.9.2-1 -> 3.9.3-1
   * geoip-database 20200609-1 -> 20200721-1
   * git 2.27.0-1 -> 2.28.0-1
   * glib2 2.64.3-2 -> 2.64.5-1
   * gnupg 2.2.20-4 -> 2.2.21-1
   * gpgme 1.13.1-7 -> 1.14.0-1
   * hwids 20200306-1 -> 20200813.1-1
   * iana-etc 20200624-1 -> 20200812-1
   * iproute2 5.7.0-1 -> 5.8.0-1
   * iputils 20190709-2 -> 20190709-3
   * jq 1.6-2 -> 1.6-3
   * json-c 0.14-4 -> 0.15-1
   * kbd 2.2.0-5 -> 2.3.0-2
   * keyutils 1.6.1-4 -> 1.6.3-1
   * ldb 1:2.1.3-1 -> 1:2.1.4-1
   * libcap 2.36-1 -> 2.42-1
   * libcups 2.3.3-1 -> 2.3.3-2
   * libgcrypt 1.8.5-2 -> 1.8.6-1
   * libidn 1.35-3 -> 1.36-1
   * libmaxminddb 1.4.2-1 -> 1.4.3-1
   * libnsl 1.2.0-2 -> 1.3.0-1
   * libp11-kit 0.23.20-5 -> 0.23.21-1
   * libpng 1.6.37-2 -> 1.6.37-3
   * libsodium 1.0.18-1 -> 1.0.18-2
   * libutil-linux 2.35.2-1 -> 2.36-1
   * libuv 1.38.0-1 -> 1.38.1-1
   * lighttpd 1.4.53-1 -> 1.4.55-2 [ignored]
   * linux-firmware 20200519.8ba6fa6-1 -> 20200721.2b823fc-1
   * linux-raspberrypi 5.4.45-1 -> 5.4.51-2
   * lmdb 0.9.25-1 -> 0.9.26-1
   * logrotate 3.16.0-1 -> 3.17.0-1
   * mkinitcpio 27-3 -> 28-1
   * mpfr 4.0.2-2 -> 4.1.0-1
   * nano 4.9.3-1 -> 5.0-1
   * nspr 4.26-1 -> 4.27-1
   * nss 3.54-1 -> 3.55-2
   * openresolv 3.10.0-1 -> 3.11.0-1
   * openssh 8.3p1-1 -> 8.3p1-3
   * p11-kit 0.23.20-5 -> 0.23.21-1
   * pacman 5.2.1-6 -> 5.2.2-1
   * pacman-contrib 1.3.0-2 -> 1.4.0-1
   * pacman-mirrorlist 20200430-1 -> 20200808-1
   * pam 1.3.1-2 -> 1.4.0-3
   * pambase 20190105.1-2 -> 20200721.1-2
   * php 7.4.7-1 -> 7.4.9-1.1
   * php-cgi 7.4.7-1 -> 7.4.9-1.1
   * php-sqlite 7.4.7-1 -> 7.4.9-1.1
   * popt 1.16-12 -> 1.18-1
   * python 3.8.3-1 -> 3.8.5-1
   * python-asn1crypto 1.3.0-1 -> 1.4.0-1
   * python-bcrypt 3.1.7-3 -> 3.2.0-1
   * python-cffi 1.14.0-3 -> 1.14.2-1
   * python-cryptography 2.9.2-1 -> 3.0-1
   * python-distlib 0.3.0-1 -> 0.3.1-1
   * python-docker 4.2.1-1 -> 4.3.1-1
   * python-dotenv 0.13.0-2 -> 0.14.0-1
   * python-html5lib 1.0.1-7 -> 1.1-1
   * python-idna 2.9-1 -> 2.10-1
   * python-lxml 4.5.1-1 -> 4.5.2-1
   * python-ordered-set 3.1.1-2 -> 4.0.2-1
   * python-pytoml 0.1.21-3 -> 0.1.21-4
   * python-setuptools 1:47.3.1-1 -> 1:49.6.0-1
   * python-urllib3 1.25.9-1 -> 1.25.10-1
   * python-yaml 5.3.1-1 -> 5.3.1-2
   * python2-distlib 0.3.0-1 -> 0.3.1-1
   * python2-importlib_resources 1.0.2-1 -> 1.0.2-2
   * python2-ordered-set 3.1.1-2 -> 3.1.1-3
   * python2-typing 3.7.4.1-1 -> 3.7.4.3-1
   * python2-wheel 0.34.2-2 -> 0.35.1-2
   * raspberrypi-bootloader 20200614-1 -> 20200820-1
   * raspberrypi-bootloader-x 20200614-1 -> 20200820-1
   * raspberrypi-firmware 20200614-1 -> 20200820-1
   * rubygems 3.1.3-1 -> 3.1.4-1
   * runc 1.0.0rc90-1 -> 1.0.0rc92-1
   * samba 4.12.3-1 -> 4.12.6-1
   * shadow 4.8.1-1 -> 4.8.1-3
   * smbclient 4.12.3-1 -> 4.12.6-1
   * sudo 1.9.1-1 -> 1.9.2-1
   * systemd 245.6-8 -> 246.2-1
   * systemd-libs 245.6-8 -> 246.2-1
   * systemd-sysvcompat 245.6-8 -> 246.2-1
   * thin-provisioning-tools 0.8.5-3 -> 0.9.0-1
   * util-linux 2.35.2-1 -> 2.36-1
   * uwsgi 2.0.19.1-2 -> 2.0.19.1-3
   * wireless-regdb 2019.06.03-2 -> 2020.04.29-1
   * xfsprogs 5.6.0-2 -> 5.7.0-3


System:

Code: Select all
KERNEL : 5.4.51-2-ARCH armv7l
CPU : ARMv7 Processor rev 4 (v7l)


I used the following set up for bluetooth on the Raspberry:
1. alarm-bluetooth-raspberrypi from AUR
2. Perform setup from https://github.com/RoEdAl/alarm-bluetoo ... nstalation
3. Edited /usr/share/dbus-1/system.d/bluetooth.conf & Enabled btusb
Code: Select all
<!-- This configuration file specifies the required security policies
     for Bluetooth core daemon to work. -->

<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent1"/>
    <allow send_interface="org.bluez.MediaEndpoint1"/>
    <allow send_interface="org.bluez.MediaPlayer1"/>
    <allow send_interface="org.bluez.Profile1"/>
    <allow send_interface="org.bluez.GattCharacteristic1"/>
    <allow send_interface="org.bluez.GattDescriptor1"/>
    <allow send_interface="org.bluez.LEAdvertisement1"/>
    <allow send_interface="org.freedesktop.DBus.ObjectManager"/>
    <allow send_interface="org.freedesktop.DBus.Properties"/>
    <allow send_interface="org.mpris.MediaPlayer2.Player"/>
  </policy>

  <policy context="default">
    <allow send_destination="org.bluez"/>
  </policy>

</busconfig>


Code: Select all
sudo lsmod | grep "btusb"
btusb                  45056  0
btrtl                  16384  1 btusb
btintel                20480  1 btusb
btbcm                  16384  1 btusb
bluetooth             376832  57 btrtl,btintel,bnep,btbcm,btusb


. Installed pacman -S bluez bluez-utils

This worked for years/months and because I do not get any error message or know where to look (in journal I did not find anything helpful, but I'm not an expert) I'm searching for help or possible ideas where to look.

Some journal message that could be related (I'm unsure when these errors did occur first time).

Code: Select all
...
Aug 26 14:43:03 raspberry-server sudo[2545]: pam_systemd_home(sudo:account): Failed to query user record: Unit dbus-org.freedesktop.home1.service not found.
Aug 26 14:43:03 raspberry-server dbus-daemon[291]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.ho>
Aug 26 14:43:03 raspberry-server audit[2545]: CRED_REFR pid=2545 uid=0 auid=1001 ses=4 msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_env,pam_faillock acct>
Aug 26 14:43:03 raspberry-server audit[2545]: USER_ACCT pid=2545 uid=1001 auid=1001 ses=4 msg='op=PAM:accounting grantors=pam_unix,pam_permit,pam_time acct="SOMEACCOUNT">
Aug 26 14:43:03 raspberry-server dbus-daemon[291]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' re>
...
Aug 26 14:25:11 raspberry-server systemd-resolved[334]: Using degraded feature set UDP instead of TCP for DNS server IP OF LOCAL DNS (pihole)
Aug 26 14:25:11 raspberry-server systemd-resolved[334]: Using degraded feature set TCP instead of UDP for DNS server IP OF LOCAL DNS (pihole)
Aug 26 14:25:11 raspberry-server systemd-resolved[334]: Using degraded feature set TCP instead of UDP for DNS server IP OF LOCAL DNS (pihole)
Aug 26 14:25:11 raspberry-server systemd-resolved[334]: Using degraded feature set UDP instead of TCP for DNS server IP OF LOCAL DNS (pihole)
Aug 26 14:25:11 raspberry-server systemd-resolved[334]: Using degraded feature set UDP instead of TCP for DNS server IP OF LOCAL DNS (pihole)
Aug 26 14:25:11 raspberry-server systemd-resolved[334]: Using degraded feature set TCP instead of UDP for DNS server IP OF LOCAL DNS (pihole)
...
Aug 24 00:32:12 raspberry-server kernel: bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
Aug 24 00:32:12 raspberry-server kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Aug 24 00:32:12 raspberry-server kernel: bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
Aug 24 00:32:12 raspberry-server kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
Aug 24 00:32:12 raspberry-server kernel: bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned.
Aug 24 00:32:12 raspberry-server kernel: bcm2835_codec: module is from the staging directory, the quality is unknown, you have been warned.
Aug 24 00:32:12 raspberry-server kernel: bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
Aug 24 00:32:12 raspberry-server kernel: bcm2835_isp: module is from the staging directory, the quality is unknown, you have been warned.
Aug 24 00:32:12 raspberry-server kernel: bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
Aug 24 00:32:12 raspberry-server kernel: bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
...
Aug 24 00:32:11 raspberry-server kernel: [vc_sm_connected_init]: failed to initialize shared memory service
Aug 24 00:32:11 raspberry-server kernel: vc_sm_cma_vchi_init: failed to open VCHI service (-1)
Aug 24 00:32:11 raspberry-server kernel: [vc_sm_connected_init]: start
Aug 24 00:32:11 raspberry-server kernel: bcm2835_vc_sm_cma_probe: Videocore shared memory driver
Aug 24 00:32:11 raspberry-server kernel: [vc_sm_connected_init]: end - returning -1
Aug 24 00:32:11 raspberry-server kernel: [vc_sm_connected_init]: failed to initialize shared memory service
Aug 24 00:32:11 raspberry-server kernel: vc_vchi_sm_init: failed to open VCHI service (-1)


Any suggestions about the issue are appreciated. Greetings!

PS: I found did previously to this post found a similar issue: viewtopic.php?f=60&t=14476
The solution there was downgrading all linux/raspberry relevant firmware. But I'm unsure in which order and if I have to be carefull to select all relevant dependencies? Also the other issue was about a earlier version of linux and raspberry firmware. My RPI did work with these onces I guess.
archARMRapberry
 
Posts: 1
Joined: Wed Aug 26, 2020 4:10 pm

Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 2 guests