lowriter crash

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

lowriter crash

Postby acorbi » Sun Sep 27, 2020 3:29 pm

Hi!

Trying to use lowriter from libreoffice-(fresh|still) (fresh or still doesn't matter, it's the same with both versions) always ends up crashing lowriter and restarting trying to recover a file. No matter if I start lowriter without a filename as parameter or with an existing one. Lowriter constantly crashes and restarts automatically trying to recover the file.

The rest of tools (lodraw, localc, loimpres, etc....) seem to work okay both in fresh and still packages.

Thanks,
A. Corbi
acorbi
 
Posts: 6
Joined: Wed Aug 05, 2020 10:31 am

[SOLVED] lowriter crash

Postby acorbi » Fri Oct 02, 2020 8:40 am

Hi all!

In case any one matters this, I've managed to nail (and solve) the problem.

1. Executing 'lowriter --norestore' produced a SIGSEV, yay! At least I had something to begin with.

2. Next I executed 'lowriter --norestore --backtrace' and got a log from gdb.

3. In that log I got this :
"Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0xa4bdbf70 in ?? () from /usr/lib/libreoffice/program/libjavaloaderlo.so
#0 0xa4bdbf70 in () at /usr/lib/libreoffice/program/libjavaloaderlo.so
#1 0xa4bd88d0 in () at /usr/lib/libreoffice/program/libjavaloaderlo.so
#2 0xbeffdcec in ()"

4. Then I remember I installed 'plantuml' that needs Java JRE, so I removed plantuml like this: "sudo pacman -Rns plantuml" , that pulled out of my system the Java JRE dependencies it needed.

5. Tried libreoffice writer and it worked!!!

6. Reinstalled plantuml again, but when asked which JRE to use I went with JRE8 instead of the latest (JRE14 I think).

7. Tried libreoffice writer and it still worked!!!

So thats my take, hope that it will be useful to everyone who could have this same problem.
acorbi
 
Posts: 6
Joined: Wed Aug 05, 2020 10:31 am


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 1 guest