Pi boot ony with hdmi attached

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

Pi boot ony with hdmi attached

Postby loki279 » Sat Jul 10, 2021 9:55 am

After upgrading the system today (new kernel also) my RP3 does boot only with a monitor attached, as a workaround I set
Code: Select all
hdmi_force_hotplug=1

in /boot/config.txt
this pi runs as a server so usually there is no display attached via hdmi.

Can someone confirm this behaviour and is this intended?

Thanks
loki279
 
Posts: 17
Joined: Tue Mar 07, 2017 7:59 am

Re: Pi boot ony with hdmi attached

Postby trigger » Sun Jul 11, 2021 6:13 am

The same behavior with my Pi2B. Not boot without HDMI cable.
trigger
 
Posts: 8
Joined: Mon Apr 25, 2016 1:40 pm

Re: Pi boot ony with hdmi attached

Postby bulletmark » Sun Jul 11, 2021 7:26 am

Same with my two Pi2B's. Both run headless as servers and failed to come up today after update. So thanks a lot loki279 for that tip about that hdmi_force_hotplug option. My Pi4 and Pi3 don't seem to have any issue.
bulletmark
 
Posts: 64
Joined: Tue Oct 13, 2015 10:17 pm

Re: Pi boot ony with hdmi attached

Postby loki279 » Sun Jul 11, 2021 9:24 am

I guess this a bug then, will fill a report when I have some time..
loki279
 
Posts: 17
Joined: Tue Mar 07, 2017 7:59 am

Re: Pi boot ony with hdmi attached

Postby dtbarch » Sun Jul 11, 2021 3:35 pm

Thanks for this confirmation.

Here, three headless Pis were updated this morning:

Raspi 2B -> ok
Raspi Zero W -> ok
Raspi 3B/3B+ -> failed

Only the failing 3B had the following

Code: Select all
dtoverlay=vc4-kms-v3d 


in /boot/config.txt

And to give you something to laugh about: I first checked the network infrastructure (router and switches) because booting went fine at the main switch (with hdmi attached) but not on the other switches....

Thanks for reporting the bug and take care
dtbarch
 
Posts: 3
Joined: Sat Feb 20, 2021 3:10 pm

Re: Pi boot ony with hdmi attached

Postby loki279 » Mon Jul 12, 2021 12:59 pm

I can confirm that
Code: Select all
    dtoverlay=vc4-kms-v3d 

set in /boot/config.txt causes this problem. After removing this entry together wirth
Code: Select all
    hdmi_force_hotplug=1 

The Pi boots normal as supposed. On this server I do not need VC4 mesa I guess so I'll leave it this way..
loki279
 
Posts: 17
Joined: Tue Mar 07, 2017 7:59 am

Re: Pi boot ony with hdmi attached

Postby martinherndl » Sun Jul 18, 2021 6:36 pm

Haha, I thought I was going crazy. It worked twice when I carried it over to my TV where I plugged it in to check what was going on.. xD thx
martinherndl
 
Posts: 7
Joined: Sat Mar 13, 2021 2:57 pm

Re: Pi boot ony with hdmi attached

Postby nickerejv » Sat Jul 24, 2021 7:16 am

this is the most annoying bug ever! It worked fine while booting with HDMI :-(
nickerejv
 
Posts: 5
Joined: Sun Mar 18, 2018 11:57 am

Re: Pi boot ony with hdmi attached

Postby graysky » Sat Jul 24, 2021 11:00 am

graysky
 
Posts: 1015
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: Pi boot ony with hdmi attached

Postby HydroDiOxide » Tue Jul 27, 2021 8:06 pm

Suffered it too... Pretty annoying indeed. Spent the whole evening figuring out what was going.
HydroDiOxide
 
Posts: 14
Joined: Mon Apr 23, 2018 1:29 pm


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 3 guests