webkit2gtk 2.8.0-2

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

webkit2gtk 2.8.0-2

Postby hendry » Thu Apr 16, 2015 7:52 am

Anyone else having issues with webkit2gtk? epiphany cannot render a Web page on my Rpi2.

I tried and failed to report an issue: https://github.com/archlinuxarm/PKGBUILDs/issues/1155

Would be great if someone else could confirm the issue, else I'm going mad. Many thanks,
hendry
 
Posts: 40
Joined: Wed Jul 31, 2013 8:28 am
Location: Singapore

Re: webkit2gtk 2.8.0-2

Postby MrRee » Thu Apr 16, 2015 12:28 pm

Hi Hendry,

I installed Surf2 and its dependencies on my ODROID-C1 , if launched with an url (eg :surf2 http://www.google.com) - in a terminal - I get a blank page, the terminal has

Code: Select all
[jason@c1 ~]$ surf2 google.com
MESA-LOADER: malformed or no PCI ID
libGL error: unable to load driver: mali_drm_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: mali_drm
which is not surprising

When I ctl-g another url, it changes the window title to the new url, gets up to 30% in loading then reverts to 0% again with a blank page with "[0%]cGISVm:T- |" (without quotes) as the window title.

EDIT:

forgot to add that when the Surf2 window is cosed that I get the following in the terminal
Code: Select all
[jason@c1 ~]$ Error receiving IPC message on socket -1 in process 699: Bad file descriptor



Hope this helps

Jase
MrRee
 
Posts: 16
Joined: Tue Jan 27, 2015 6:50 pm

Re: webkit2gtk 2.8.0-2

Postby hendry » Sat Apr 18, 2015 8:36 am

Thank you Jase for confirming the issue!

I can confirm error messages like Error receiving IPC message on socket -1 in process 405: Bad file descriptor when I try launch the inspector. Then it gets stucks and seems to soak up all the memory.



If you can think of ways of how to debug this, please add to https://bugs.webkit.org/show_bug.cgi?id=143817

Btw I have tried the debugging tips in http://trac.webkit.org/wiki/WebKitGTK/Debugging and I don't think those debugging exports work with say surf2 and run-minibrowser is not packaged. I know building on my rpi2 is pretty DAMN painful and I don't have a cross build env. I wonder if we can ask alarm devs to please produce a debug build.
hendry
 
Posts: 40
Joined: Wed Jul 31, 2013 8:28 am
Location: Singapore


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 1 guest